简单的数论2

F - 简单的数论2
Crawling in process... Crawling failed Time Limit:2000MS     Memory Limit:32768KB     64bit IO Format:%lld & %llu

Description

Input

Output

Sample Input

Sample Output

Hint

Description

Bamboo Pole-vault is a massively popular sport in Xzhiland. And Master Phi-shoe is a very popular coach for his success. He needs some bamboos for his students, so he asked his assistant Bi-Shoe to go to the market and buy them. Plenty of Bamboos of all possible integer lengths (yes!) are available in the market. According to Xzhila tradition,

Score of a bamboo = Φ (bamboo's length)

(Xzhilans are really fond of number theory). For your information, Φ (n) = numbers less than n which are relatively prime (having no common divisor other than 1) to n. So, score of a bamboo of length 9 is 6 as 1, 2, 4, 5, 7, 8 are relatively prime to 9.

The assistant Bi-shoe has to buy one bamboo for each student. As a twist, each pole-vault student of Phi-shoe has a lucky number. Bi-shoe wants to buy bamboos such that each of them gets a bamboo with a score greater than or equal to his/her lucky number. Bi-shoe wants to minimize the total amount of money spent for buying the bamboos. One unit of bamboo costs 1 Xukha. Help him.

Input

Input starts with an integer T (≤ 100), denoting the number of test cases.

Each case starts with a line containing an integer n (1 ≤ n ≤ 10000) denoting the number of students of Phi-shoe. The next line contains n space separated integers denoting the lucky numbers for the students. Each lucky number will lie in the range [1, 106].

Output

For each case, print the case number and the minimum possible money spent for buying the bamboos. See the samples for details.

Sample Input

3

5

1 2 3 4 5

6

10 11 12 13 14 15

2

1 1

Sample Output

Case 1: 22 Xukha

Case 2: 88 Xukha

Case 3: 4 Xukha

题意:

首先给出T组数据,给一些数ai(第 i 个数),ai这些数代表的是某个数欧拉函数的值,我们要求出数 pi 的欧拉函数值大于等于ai。而我们要求的就是这些 pi 这些数字的和sum,而且我们想要sum最小,求出sum至少是多少。

解题思路:筛选法求素数,然后找比幸运值大的挨得近的素数,,把素数相加就行了

#include<stdio.h>
#include<iostream>
using namespace std;
#define maxn 1010000
int a[10000];
int b[maxn];
int main()
{
    b[1]=1;
    b[0]=1;
   for(int i=2;i<=maxn;i++)筛法求素数
   {
       if(!b[i])
       {
        for(int j=2*i; j<=maxn; j+=i)
        {
            b[j]=1;
        }
       }
   }
    int t;
    scanf("%d",&t);
    int g=0;
    while(t--)
    {g++;
        int n,j;
        scanf("%d",&n);
        for(int i=0; i<n; i++)
        {
            scanf("%d",&a[i]);
        }
        long long int ni=0;
        for(int i=0;i<n;i++)
        {
           for(int j=a[i]+1;;j++)//找比她大的素数
            {
                if(!b[j])
                { 
                    ni+=j;
                    break;
                }
            }
        }
        printf("Case %d: ",g);
     printf("%lld Xukha\n",ni);
    }
}

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值