Matrix

                                                                                                                                    Matrix
Time Limit: 3000MS Memory Limit: 65536K
Total Submissions: 25368 Accepted: 9403

Description

Given an N*N matrix A, whose elements are either 0 or 1. A[i, j] means the number in the i-th row and j-th column. Initially we have A[i, j] = 0 (1 <= i, j <= N).

We can change the matrix in the following way. Given a rectangle whose upper-left corner is (x1, y1) and lower-right corner is (x2, y2), we change all the elements in the rectangle by using "not" operation (if it is a '0' then change it into '1' otherwise change it into '0'). To maintain the information of the matrix, you are asked to write a program to receive and execute two kinds of instructions.

1. C x1 y1 x2 y2 (1 <= x1 <= x2 <= n, 1 <= y1 <= y2 <= n) changes the matrix by using the rectangle whose upper-left corner is (x1, y1) and lower-right corner is (x2, y2).
2. Q x y (1 <= x, y <= n) querys A[x, y].

Input

The first line of the input is an integer X (X <= 10) representing the number of test cases. The following X blocks each represents a test case.

The first line of each block contains two numbers N and T (2 <= N <= 1000, 1 <= T <= 50000) representing the size of the matrix and the number of the instructions. The following T lines each represents an instruction having the format "Q x y" or "C x1 y1 x2 y2", which has been described above.

Output

For each querying output one line, which has an integer representing A[x, y].

There is a blank line between every two continuous test cases.

Sample Input

1
2 10
C 2 1 2 2
Q 2 2
C 2 1 2 1
Q 1 1
C 1 1 2 1
C 1 2 1 2
C 1 1 2 2
Q 1 1
C 1 1 2 1
Q 2 1

Sample Output

1
0
0
1
题意:给一个N*N的矩阵,里面的值不是0,就是1。初始时每一个格子的值为0。
 现对该矩阵有两种操作:(共T次)
 1.C x1 y1 x2 y2:将左上角为(x1, y1),右下角为(x2, y2)这个范围的子矩阵里的值全部取反。
 2.Q x y:查询矩阵中第i行,第j列的值。
 (2 <= N <= 1000, 1 <= T <= 50000)
 思路:参见国家集训队论文:武森《浅谈信息学竞赛中的“0”和“1”》
 1. 根据这个题目中介绍的这个矩阵中的数的特点不是 1 就是 0,这样我们只需记录每个格子改变过几次,即可判断这个格子的数字。
 2. 先考虑一维的情况:
 若要修改[x,y]区间的值,其实可以先只修改 x 和 y+1 这两个点的值(将这两个点的值加1)。查询k点的值时,其修改次数即为 sum(cnt[1] + … + cnt[k])。
 3. 二维的情况:
 道理同一维。要修改范围[x1, y1, x2, y2],只需修改这四个点:(x1,y1), (x1,y2+1), (x2+1,y1), (x2+1,y2+1)。查询点(x,y)的值时,其修改次数为 sum(cnt[1, 1, x, y])。
 4. 而区间求和,便可用树状数组来实现。
#include<stdio.h>
#include<string.h>
#include<iostream>
using namespace std;
int c[2000][2000];
int n,m;
int lowbit(int i)
{
    return i&-i;
}
void add(int i,int j,int zhi)
{
    for(int k=i; k<2020; k+=lowbit(k))
    {
        for(int p=j; p<2020; p+=lowbit(p))
        {
            c[k][p]+=zhi;
        }
    }
}
int sum(int i,int j)
{
    int he=0;
    for(int k=i; k>0; k-=lowbit(k))
    {
        for(int p=j; p>0; p-=lowbit(p))
        {
            he+=c[k][p];
        }
    }
    return he;
}
int main()
{
    int t;
    scanf("%d",&t);
    while(t--)
    {
        scanf("%d %d",&n,&m);
        memset(c,0,sizeof(c));
        while(m--)
        {
            char a[10];
            int x,y;
            scanf("%s%d%d",a,&x,&y);
            if(a[0]=='C')
            {
                int ha,haha;
                scanf("%d%d",&ha,&haha);
                add(x, y, 1);
                add(x, haha+1, 1);
                add(ha+1, y, 1);
                add(ha+1, haha+1, 1);
            }
            else
            {
                printf("%d\n",sum(x,y)%2);
            }
        }
        printf("\n");
    }
}


  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值