A - Broken Clock

A - Broken Clock
Crawling in process... Crawling failed Time Limit:1000MS    Memory Limit:262144KB     64bit IO Format:%I64d & %I64u

Description

Input

Output

Sample Input

Sample Output

Hint

Description

You are given a broken clock. You know, that it is supposed to show time in 12- or 24-hoursHH:MM format. In 12-hours format hours change from1 to 12, while in 24-hours it changes from0 to 23. In both formats minutes change from0 to 59.

You are given a time in format HH:MM that is currently displayed on the broken clock. Your goal is to change minimum number of digits in order to make clocks display the correct time in the given format.

For example, if 00:99 is displayed, it is enough to replace the second9 with 3 in order to get00:39 that is a correct time in 24-hours format. However, to make00:99 correct in 12-hours format, one has to change at least two digits. Additionally to the first change one can replace the second0 with 1 and obtain01:39.

Input

The first line of the input contains one integer 12 or24, that denote 12-hours or 24-hours format respectively.

The second line contains the time in format HH:MM, that is currently displayed on the clock. First two characters stand for the hours, while next two show the minutes.

Output

The only line of the output should contain the time in format HH:MM that is a correct time in the given format. It should differ from the original in as few positions as possible. If there are many optimal solutions you can print any of them.

Sample Input

Input
24
17:30
Output
17:30
Input
12
17:30
Output
07:30
Input
24
99:99
Output
09:09

题意

12小时制的话,时钟是从1开始到12的。

24小时制的话,时钟是从0开始到23的

然后给你一个小时制度,然后再给你一个时间,问你这个时间是否合法,如果不合法的话,你需要修改最少的数字,使得这个时间合法 。

#include<stdio.h>
int main()
{
    int n;
    while(scanf("%d",&n)!=-1)
    {
        char a[100];
        scanf("%s",a);
         int we=0,ni=0;
           we=(a[0]-'0')*10+(a[1]-'0');
           ni=(a[3]-'0')*10+(a[4]-'0');
        if(n==12)
        {
            if (we >=1 && we<= 12);
            else
            {if(we%10==0)
            {
                we=10;
            }
                else we %= 10;
            }
			if (ni >= 0 && ni <= 59);
			else ni%= 10;
        }
        else
        {
           if (we >= 0 && we<= 23);
			else we %= 10;
			if (ni >= 0 && ni <= 59);
			else ni%= 10;
        }
        if(we<=9&&ni<=9)
        printf("0%d:0%d\n",we,ni);
       else if(we<=9&&ni>=10)
            printf("0%d:%d\n",we,ni);
          else  if(we>=10&&ni<=9)
        printf("%d:0%d\n",we,ni);
        else
        printf("%d:%d\n",we,ni);
    }
}

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值