Friends

Alice lives in the country where people like to make friends. The friendship is bidirectional and if any two person have no less than k friends in common, they will become friends in several days. Currently, there are totally n people in the country, and m friendship among them. Assume that any new friendship is made only when they have sufficient friends in common mentioned above, you are to tell how many new friendship are made after a sufficiently long time.

Input

There are multiple test cases.

The first lien of the input contains an integer T (about 100) indicating the number of test cases. Then T cases follow. For each case, the first line contains three integers n, m, k (1 ≤ n ≤ 100, 0 ≤ mn×(n-1)/2, 0 ≤ kn, there will be no duplicated friendship) followed by m lines showing the current friendship. The ith friendship contains two integers ui, vi (0 ≤ ui, vi < n, ui ≠ vi) indicating there is friendship between person ui and vi.

Note: The edges in test data are generated randomly.

Output

For each case, print one line containing the answer.

Sample Input

3
4 4 2
0 1
0 2
1 3
2 3
5 5 2
0 1
1 2
2 3
3 4
4 0
5 6 2
0 1
1 2
2 3
3 4
4 0
2 0

Sample Output

2

0

4

题意:如果两个人有共同的朋友的个数是>=k的,则这两个朋友可以交朋友,问你新增的朋友关系有几对

思路:因为n比较小,所以暴力解决就行了,找每两个人的共同朋友,大于等于k,,这两个人就是朋友。因为是不断更新的关系,所以可以用个for循环,如果朋友关系没法更新了,那么就跳出这个循环就行了。。。当时看懂这个题的时候已经没时间了,,前面浪费太多时间了,就是因为前面题意看了好久好久没懂。哎

#include<stdio.h>
#include<iostream>
#include<string.h>
#include<algorithm>
#include<vector>
using namespace std;
struct node
{
    int x,y;
} s[1000];
int we[1000][1000];
//vector<int>we[1000];
int main()
{
    int t;
    scanf("%d",&t);
    while(t--)
    {
        int n,m,k;
        scanf("%d%d%d",&n,&m,&k);
        memset(we,0,sizeof(we));
        for(int i=0; i<m; i++)
        {
            scanf("%d%d",&s[i].x,&s[i].y);
            we[s[i].x][s[i].y]=1;
            we[s[i].y][s[i].x]=1;
//           we[s[i].x].push_back(s[i].y);
//           we[s[i].y].push_back(s[i].x);
        }
        int sum1=0;
        int p=0;
       for(int y1=0;;y1++)
       {
           p=0;
            for(int i=0; i<n; i++)
            {
                for(int j=i+1; j<n; j++)
                {
                    if(we[i][j]==0)
                    {
                   int sum=0;
                    for(int k1=0; k1<n; k1++)
                    {
                        if(we[i][k1]==1&&we[j][k1]==1)
                        {
                            sum++;
                        }
                    }
                    //printf("^^^%d\n",sum);
                    if(sum>=k)
                    {
                        sum1++;
                        p=1;
                        we[i][j]=1;
                        we[j][i]=1;
                    }
                    }
                }
            }
            if(p==0)
                break;
        }
        printf("%d\n",sum1);
    }
}



  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值