Largest Point

Given the sequence A A with n n integers t1,t2,,tn t1,t2,⋯,tn. Given the integral coefficients a a and b b. The fact that select two elements ti ti and tj tj of A A and ij i≠j to maximize the value of at2i+btj ati2+btj, becomes the largest point. Input
An positive integer T T, indicating there are T T test cases.
For each test case, the first line contains three integers corresponding to n (2n5×106), a (0|a|106) n (2≤n≤5×106), a (0≤|a|≤106) and b (0|b|106) b (0≤|b|≤106). The second line contains n n integers t1,t2,,tn t1,t2,⋯,tn where 0|ti|106 0≤|ti|≤106 for 1in 1≤i≤n.

The sum of n n for all cases would not be larger than 5×106 5×106.
Output
The output contains exactly T T lines.
For each test case, you should output the maximum value of at2i+btj ati2+btj.
Sample Input
2

3 2 1
1 2 3

5 -1 0
-3 -3 0 3 3
Sample Output
Case #1: 20
Case #2: 0
就是求a1*a*a+b1*a的最大值,可以贪心求解,先把a1*a*a用b数组存起来,再用c数组把b1*a存起来,最后比较两个数组最大是的id是否一样,一样的就比较b数组的最大值+c数组的次大值和b数组的次大值+c数组的最大值的大小就行,如果不相等就直接输出两个的最大值的和
#include <stdio.h>
#include <algorithm>
#include <iostream>
using namespace std;
const int maxn=5e6+10;
int n,a1,b1;
struct node
{
    int id;
    long long x;
    bool operator <(const node &a) const
    {
        return x<a.x;
    }
}b[maxn],c[maxn];
int main()
{
    int t,T=1;
    scanf("%d",&t);
    while(t--)
    {
        scanf("%d%d%d",&n,&a1,&b1);
        for(int i=0;i<n;i++)
        {
            long long a;
            scanf("%I64d",&a);
            b[i].x=a1*a*a;
            c[i].x=b1*a;
            b[i].id=c[i].id=i;
        }
        sort(b,b+n);
        sort(c,c+n);
        printf("Case #%d: ",T++);
        if(b[n-1].id!=c[n-1].id)
        {
            printf("%I64d\n",b[n-1].x+c[n-1].x);
            continue;
        }
        printf("%I64d\n",max(b[n-1].x+c[n-2].x,b[n-2].x+c[n-1].x));
    }
}


  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值