HDOJ 5461 Largest Point(沈阳网络赛)(思维)

时间限制: 1 Sec  内存限制: 128 MB
提交: 104  解决: 35
[提交] [状态] [讨论版] [命题人:admin]

题目描述

Given the sequence A with n integers t1 , t2 , …… , tn . Given the integral coefficients a and b. The fact that select two elements ti and tj of A and i ≠ j to maximize the value of  becomes the largest point.

 

输入

An positive integer T, indicating there are T test cases. For each test case, the first line contains three integers corresponding to n (2 ≤ n ≤ 5×106 ), a (0 ≤ |a| ≤ 106 ) and b (0 ≤ |b| ≤ 106 ). The second line contains n integers t1 , t2 , …… , tn where 0 ≤ |ti | ≤ 106 for 1 ≤ i ≤ n.
The sum of n for all cases would not be larger than 5 × 106 .

 

输出

The output contains exactly T lines. For each test case, you should output the maximum value of 

 

样例输入

2
3 2 1
1 2 3
5 -1 0
-3 -3 0 3 3

 

样例输出

Case #1: 20
Case #2: 0
#include<bits/stdc++.h>
using namespace std;
#define maxn 1000010
#define ll long long
#define M(a) memset(a,0,sizeof(a))
long long c[maxn];
struct node{
    ll num,inx;
}d[maxn],e[maxn];
bool cmp(node a,node b){
    if(a.num==b.num) return a.inx<b.inx;
    return a.num>b.num;
}

int main()
{
    int t,n,f=0;
    long long a,b;
    scanf("%d",&t);
    while(t--&&scanf("%d%lld%lld",&n,&a,&b)){
        M(c);
        for(int i=0;i<n;i++){
            scanf("%lld",&c[i]);
            d[i].num=a*c[i]*c[i];
            d[i].inx=i;
            e[i].num=b*c[i];
            e[i].inx=i;
        }
        ll ans=0;
        sort(d,d+n,cmp);
        sort(e,e+n,cmp);
        if(d[0].inx==e[0].inx){
            ans=max(d[0].num+e[1].num,d[1].num+e[0].num);
        }else{
            ans=d[0].num+e[0].num;
        }
        f++;
        printf("Case #%d: %lld\n",f,ans);
    }
}

 

  • 1
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值