Largest Point(想法题+贪心思想)

181 篇文章 0 订阅
173 篇文章 3 订阅


Link:http://acm.hdu.edu.cn/showproblem.php?pid=5461


Largest Point

Time Limit: 1500/1000 MS (Java/Others)    Memory Limit: 65535/32768 K (Java/Others)
Total Submission(s): 109    Accepted Submission(s): 45


Problem Description
Given the sequence  A  with  n  integers  t1,t2,,tn . Given the integral coefficients  a  and  b . The fact that select two elements  ti  and  tj  of  A  and  ij  to maximize the value of  at2i+btj , becomes the largest point.
 

Input
An positive integer  T , indicating there are  T  test cases.
For each test case, the first line contains three integers corresponding to  n (2n5×106), a (0|a|106)  and  b (0|b|106) . The second line contains  n integers  t1,t2,,tn  where  0|ti|106  for  1in .

The sum of  n  for all cases would not be larger than  5×106 .
 

Output
The output contains exactly  T  lines.
For each test case, you should output the maximum value of  at2i+btj .
 

Sample Input
  
  
2 3 2 1 1 2 3 5 -1 0 -3 -3 0 3 3
 

Sample Output
  
  
Case #1: 20 Case #2: 0
 

Source
 


AC code:

#include<iostream>
#include<algorithm>
#include<cstring>
#include<cstdio>
#include<cmath>
#include<queue>
#include<map>
#include<stack>
#include<vector>
#define LL long long
#define MAXN 1000010
using namespace std;

struct node{
	int id;
	LL v;
}aa[MAXN],bb[MAXN];
LL t[5*MAXN];
bool cmp(node a,node b)
{
	return a.v>b.v;
}
LL ans;
int main()
{
	int T,n,a,b,i,cas;
	scanf("%d",&T);
	cas=0;
	while(T--)
	{
		cas++;
		scanf("%d%d%d",&n,&a,&b);
		for(i=1;i<=n;i++)
		{
			scanf("%I64d",&t[i]);
			aa[i].v=a*t[i]*t[i];
			bb[i].v=b*t[i];
			aa[i].id=i;
			bb[i].id=i;
		}
		sort(aa+1,aa+n+1,cmp);
		sort(bb+1,bb+n+1,cmp);
		if(aa[1].id!=bb[1].id)
		{
			ans=aa[1].v+bb[1].v;
		}
		else
		{
			LL ans1=aa[1].v+bb[2].v;
			LL ans2=aa[2].v+bb[1].v;
			ans=max(ans1,ans2);
		}
		printf("Case #%d: %I64d\n",cas,ans);
	 } 
  	return 0;
}


  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 打赏
    打赏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包

打赏作者

林下的码路

你的鼓励将是我创作的最大动力

¥1 ¥2 ¥4 ¥6 ¥10 ¥20
扫码支付:¥1
获取中
扫码支付

您的余额不足,请更换扫码支付或充值

打赏作者

实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值