1092 A+B for Input-Output Practice (IV)

Problem Description

Your task is to Calculate the sum of some integers.

Input

Input contains multiple test cases. Each test case contains a integer N, and then N integers follow in the same line. A test case starting with 0 terminates the input and this test case is not to be processed.

Output

For each group of input integers you should output their sum in one line, and with one line of output for each line in input.

Sample Input

4 1 2 3 4
5 1 2 3 4 5
0

Sample Output

10
15

解题过程

#include<stdio.h>
int main()
{
   int n,x,sum;
   while(scanf("%d",&n)&&n!=0)
   {
       sum = 0;
       while(n--)
       {
           scanf("%d",&x);
           sum+=x;
       }
       printf("%d\n",sum);
   }
   return 0;
}

解题总结

1.while语句的一般形式为:while(表达式)语句其中表达式是循环条件,语句为循环体。
2.计算“表达式”的值,当值为“非0”时,执行循环体语句,当值为假时,输出值。
3.例如计算从1加到100的值,当“i≤100”时,进入while的循环结构,当“i>100”时,输出结果。
while 的执行顺序:当表达式为真,则执行下面的语句;语句执行完之后再判断表达式是否为真,如果为真,再次执行下面的语句;然后再判断表达式是否为真……就这样一直循环下去,直到表达式为假,跳出循环。

心得感受

题目本身不是很有难度,只是自己想的复杂了,还有就是对基本的while函数运用不够熟练,想的不够全面。另外对scanf函数的有了新的认识,知识需要细化和理解。加油!!!

  • 1
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值