1.4A+Bfor Input-Output Practice (IV)(附翻译)


Time Limit: 2000/1000 MS (Java/Others) Memory Limit: 65536/32768 K (Java/Others)

Total Submission(s): 31220 Accepted Submission(s): 17124

Problem Description

Your task is to Calculate the sum of some integers.

 

Input

Input contains multiple test cases. Each test case contains a integer N, and then N integers follow in the same line. A test case starting with 0 terminates the input and this test case is not to be processed.

 输入包含多个测试用例。 每个测试用例都包含一个整数N,然后N个整数在同一行中。 以0开始的测试用例会终止输入,并且不会处理该测试用例。

Output

For each group of input integers you should output their sum in one line, and with one line of output for each line in input.

 对于每组输入整数,您应该在一行中输出它们的总和,并且在输入中为每行输出一行输出。

Sample Input

4 1 2 3 4
5 1 2 3 4 5
0

 

Sample Output

10
15

 

 c++

#include<iostream>
using namespace std;
int main(){
	int a,b,sum;
	while(cin>>a){
		sum=0;//sum要提前赋初始值,而且赋值的位置有讲究
		if(a==0)
			break;//当输入0,退出
		else{
			while(a>0){
				a--;
				cin>>b;
				sum=sum+b;
			}
			cout<<sum<<endl;
		}	
	}	
	return 0;
}

运行截图


评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值