D - Back and Forth AtCoder - 2282

Dolphin resides in two-dimensional Cartesian plane, with the positive x-axis pointing right and the positive y-axis pointing up.

Currently, he is located at the point  (sx,sy). In each second, he can move up, down, left or right by a distance of  1.
Here, both the  x- and  y-coordinates before and after each movement must be integers.
He will first visit the point  (tx,ty) where  sx<tx and  sy<ty, then go back to the point  (sx,sy), then visit the point  (tx,ty) again, and lastly go back to the point  (sx,sy).
Here, during the whole travel, he is not allowed to pass through the same point more than once, except the points  (sx,sy) and  (tx,ty).
Under this condition, find a shortest path for him.Constraints

  • −1000sx<tx1000
  • −1000sy<ty1000
  • sx,sy,tx and ty are integers.
Input

The input is given from Standard Input in the following format:

sx sy tx ty
Output

Print a string S that represents a shortest path for Dolphin.
The i-th character in S should correspond to his i-th movement.
The directions of the movements should be indicated by the following characters:

  • U: Up
  • D: Down
  • L: Left
  • R: Right

If there exist multiple shortest paths under the condition, print any of them.

Sample Input 1

0 0 1 2
Sample Output 1

UURDDLLUUURRDRDDDLLU

One possible shortest path is:

  • Going from (sx,sy) to (tx,ty) for the first time: (0,0) → (0,1) → (0,2) → (1,2)
  • Going from (tx,ty) to (sx,sy) for the first time: (1,2) → (1,1) → (1,0) → (0,0)
  • Going from (sx,sy) to (tx,ty) for the second time: (0,0) → (−1,0) → (−1,1) → (−1,2) → (−1,3) → (0,3) → (1,3) → (1,2)
  • Going from (tx,ty) to (sx,sy) for the second time: (1,2) → (2,2) → (2,1) → (2,0) → (2,1) → (1,1) → (0,1) → (0,0)
Sample Input 2

-2 -2 1 1
Sample Output 2

UURRURRDDDLLDLLULUUURRURRDDDLLDL

AC:

#include<stdio.h>

int main()
{
int a,b,c,d;
int m,n,i;
scanf("%d%d%d%d",&a,&b,&c,&d);
m=d-b;n=c-a;
for(i=0;i<m;i++)
 printf("U");
for(i=0;i<n;i++)
 printf("R");
for(i=0;i<m;i++)
 printf("D");
for(i=0;i<n;i++)
 printf("L");
int a1=a-1;
int d1=d+1;
printf("L");
m=d1-b;n=c-a1;
for(i=0;i<m;i++)
 printf("U");
for(i=0;i<n;i++)
 printf("R");

printf("D");
printf("R");
int c1=c+1;
int b1=b-1;
m=d-b1;n=c1-a;

for(i=0;i<m;i++)
 printf("D");
for(i=0;i<n;i++)
 printf("L");
printf("U");
return 0;
}
  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值