J - Traveling AtCoder - 3875

Problem Statement

AtCoDeer the deer is going on a trip in a two-dimensional plane. In his plan, he will depart from point (0,0) at time 0, then for each i between 1 and N(inclusive), he will visit point (xi,yi) at time ti.

If AtCoDeer is at point (x,y) at time t, he can be at one of the following points at time t+1(x+1,y)(x1,y)(x,y+1) and (x,y1). Note that he cannot stay at his place. Determine whether he can carry out his plan.

Constraints

  • 1  N  105
  • 0  xi  105
  • 0  yi  105
  • 1  ti  105
  • ti < ti+1 (1  i  N1)
  • All input values are integers.
Input

Input is given from Standard Input in the following format:

N
t1 x1 y1
t2 x2 y2
:
tN xN yN
Output

If AtCoDeer can carry out his plan, print Yes; if he cannot, print No.

Sample Input 1

2
3 1 2
6 1 1
Sample Output 1

Yes

For example, he can travel as follows: (0,0)(0,1)(1,1)(1,2)(1,1)(1,0), then (1,1).

Sample Input 2

1
2 100 100
Sample Output 2

No

It is impossible to be at (100,100) two seconds after being at (0,0).

Sample Input 3

2
5 1 1
100 1 1
Sample Output 3

No

AC:

#include<stdio.h>

#include<string.h>

#include<math.h>
#include<algorithm>
using namespace std;
int t[100005],x[100005],y[100005];
int main()
{
int n,i,f;
scanf("%d",&n);
f=0;
for(i=0;i<n;i++)
{
scanf("%d%d%d",&t[i],&x[i],&y[i]);
if(x[i]+y[i]>t[i])
{
f=1;
}
}
for(i=1;i<n;i++)
{
int m,c;
m=t[i]-t[i-1];
c=abs(x[i]-x[i-1])+abs(y[i]-y[i-1]);
if((m%2)!=(c%2))
{
f=1;break;
}  
}
if(f==1)
 printf("No\n");
else
 printf("Yes\n");
return 0;
}
  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值