1408201651-hd-GPA.cpp

GPA

Time Limit: 2000/1000 MS (Java/Others) Memory Limit: 32768/32768 K (Java/Others)

Total Submission(s): 3341 Accepted Submission(s): 1354

 
Problem Description
Each course grade is one of the following five letters: A, B, C, D, and F. (Note that there is no grade E.) The grade A indicates superior achievement , whereas F stands for failure. In order to calculate the GPA, the letter grades A, B, C, D, and F are assigned the following grade points, respectively: 4, 3, 2, 1, and 0.
 
Input
The input file will contain data for one or more test cases, one test case per line. On each line there will be one or more upper case letters, separated by blank spaces.
 
Output
Each line of input will result in exactly one line of output. If all upper case letters on a particular line of input came from the set {A, B, C, D, F} then the output will consist of the GPA, displayed with a precision of two decimal places. Otherwise, the message "Unknown letter grade in input" will be printed.
 
Sample Input
A B C D F
B F F C C A
D C E F
 
Sample Output
2.00
1.83
Unknown letter grade in input
 

题目大意

      给你一系列大写字母代表学生的成绩。A=4,B=3,C=2,D=1,F=0。输出该学生的平均分数,若出现不属于{'A','B','C','D','F'}的大写字母,则输出Unknown letter grade in input。

 

错误原因

       一开始以为除了那五个大写字母之外,会出现的只有'E',这才导致了错误。

 

解题思路

       因为不确定给出你的大写字母的次数,所以你只能用gets()输入一串字符串。然后在对' '(空格)另外考虑。

 

代码

<span style="font-size:18px;">#include<stdio.h>
#include<string.h>
char s[1000];
int in(char a)
{
    if(a=='A')
        return 4;
    else if(a=='B')
        return 3;
    else if(a=='C')
        return 2;
    else if(a=='D')
        return 1;
    else if(a=='F')
        return 0;
    else if(a==' ')
        return 5;
    else
        return -1;
    //输入的只有空格和大写字母(A、B、C、D、E、F、G、H...) 
}
int main()
{
    int i,j,k,l,sum;
    int len;
    while(gets(s)!=NULL)
    {
        len=strlen(s);
        sum=0;
        k=0;
        l=0;
        for(i=0;i<len;i++)
        {
            j=in(s[i]);
            if(j>-1&&j<5)
            {
                sum+=j;
                l++;
            }
            else if(j==-1)
            {
                k=1;
                break;
            }
        }
        if(k==1)
            printf("Unknown letter grade in input\n");
        else
            printf("%.2lf\n",sum/(l*1.0));
    }
    return 0;
}
</span>


 

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值