1409221809-hd-Number Sequence

Number Sequence

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 65536/32768 K (Java/Others)

Total Submission(s): 1328    Accepted Submission(s): 522


 

Problem Description
A number sequence is defined as follows:

f(1) = 1, f(2) = 1, f(n) = (A * f(n - 1) + B * f(n - 2)) mod 7.

Given A, B, and n, you are to calculate the value of f(n).
Input
The input consists of multiple test cases. Each test case contains 3 integers A, B and n on a single line (1 <= A, B <= 1000, 1 <= n <= 100,000,000). Three zeros signal the end of input and this test case is not to be processed.
Output
For each test case, print the value of f(n) on a single line.
Sample Input
1 1 3
1 2 10
0 0 0
Sample Output
2
5
题目大意
      根据题目给定的公式解决。
解题思路
       这道题用到了同余定理,但是如果单纯的运用同余定理进行暴力求解,会超出内存。最好的方法是仔细观察题目给定的公式,为什么要对7取余呢?这么大的数据范围肯定会存在循环节,循环电石什么呢?其实我也不知道怎么找,只知道48是一个循环,,
代码
#include<stdio.h>
int f[48];
int main()
{
	int a,b,n;
	int i,j,k;
	while(scanf("%d%d%d",&a,&b,&n)&&a+b+n)
	{
		f[1]=f[2]=1;
		for(i=3;i<=n%48;i++)
	//要找循环节 
		{
			j=f[i-1]*a%7;
			k=f[i-2]*b%7;
			f[i]=(j+k)%7;
		}
		printf("%d\n",f[n%48]);
	}
	return 0;
}

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值