HDU 1079 日期游戏 博弈论相关

Calendar Game

Time Limit: 5000/1000 MS (Java/Others)    Memory Limit: 65536/32768 K (Java/Others)
Total Submission(s): 2321    Accepted Submission(s): 1316


Problem Description
Adam and Eve enter this year’s ACM International Collegiate Programming Contest. Last night, they played the Calendar Game, in celebration of this contest. This game consists of the dates from January 1, 1900 to November 4, 2001, the contest day. The game starts by randomly choosing a date from this interval. Then, the players, Adam and Eve, make moves in their turn with Adam moving first: Adam, Eve, Adam, Eve, etc. There is only one rule for moves and it is simple: from a current date, a player in his/her turn can move either to the next calendar date or the same day of the next month. When the next month does not have the same day, the player moves only to the next calendar date. For example, from December 19, 1924, you can move either to December 20, 1924, the next calendar date, or January 19, 1925, the same day of the next month. From January 31 2001, however, you can move only to February 1, 2001, because February 31, 2001 is invalid. 

A player wins the game when he/she exactly reaches the date of November 4, 2001. If a player moves to a date after November 4, 2001, he/she looses the game. 

Write a program that decides whether, given an initial date, Adam, the first mover, has a winning strategy. 

For this game, you need to identify leap years, where February has 29 days. In the Gregorian calendar, leap years occur in years exactly divisible by four. So, 1993, 1994, and 1995 are not leap years, while 1992 and 1996 are leap years. Additionally, the years ending with 00 are leap years only if they are divisible by 400. So, 1700, 1800, 1900, 2100, and 2200 are not leap years, while 1600, 2000, and 2400 are leap years.
 

Input
The input consists of T test cases. The number of test cases (T) is given in the first line of the input. Each test case is written in a line and corresponds to an initial date. The three integers in a line, YYYY MM DD, represent the date of the DD-th day of MM-th month in the year of YYYY. Remember that initial dates are randomly chosen from the interval between January 1, 1900 and November 4, 2001. 
 

Output
Print exactly one line for each test case. The line should contain the answer "YES" or "NO" to the question of whether Adam has a winning strategy against Eve. Since we have T test cases, your program should output totally T lines of "YES" or "NO". 
 

Sample Input
  
  
3 2001 11 3 2001 11 2 2001 10 3
 

Sample Output
  
  
YES NO NO
 


   题目大意和解题方法 在代码中已经表明, 已经 AC  水题
源代码:
#include<iostream>
using namespace std;

int main()
{
    //题目大意 很简单,给定一个时间间隔内的某个时间 , 问哪个先到目标日期 到了 那么赢
    //这是易大哥博弈问题
    //解题方法 博弈论做的比较少具体方法网上百度来一下
    //每次时间变换的方法不过是时间加1 或者日期 加 1 如何进行博弈判断?
    //首先目标日期是 2000 . 11. 4日 月份是奇数 日期是偶数 两个人最终如果有一个人胜利的话进行的次数是
    //可以知道最终的结果是11. 4 日为两个数的和为偶数
    //其次最终 月份加 1 或者日期 加 1 值可能改变两个和的奇偶性
    //只是在特殊日期是会出现奇偶的性质变换, 但是如果你想赢 先手是不会选择在特殊日期选择时间的 因此特殊时间之可能出现在初始
    //现在用int 型表示年月日 偶 奇 偶 奇 可知先手为偶 是必胜的
    //只有两个特殊日期 9. 30 ,11 . 30  930 -- 10 .1  11- 30 -- 12 - 1
    int y, m, d;
    int t ;
    cin>>t;
    while(t--)
    {
        cin>>y>>m>>d;
        if((m+d)%2 == 0 ||  d == 30&&(m ==9 || m ==11))
        {
            cout<<"YES"<<endl;
        }
        else
        {
            cout<<"NO"<<endl;
        }
    }
    return 0;
 }





评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包

打赏作者

wangxiaoming

你的鼓励将是我创作的最大动力

¥1 ¥2 ¥4 ¥6 ¥10 ¥20
扫码支付:¥1
获取中
扫码支付

您的余额不足,请更换扫码支付或充值

打赏作者

实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值