OJ Problem 3445 C#委托、类和事件的验证

题目描述

程序由两部分组成,如下代码所示。第一部分定义了委托、类和事件。第二部分进行验证。  

using System;
namespace HelloWorldApplication
{
    public delegate void DelegateRing();
    public class Bell{
        public event DelegateRing Ring;
        public void OnRing(){ Ring(); }
    }
/
            
            请填写代码

/
    class HelloWorld
    {
        static void Main(string[] args)
        {
            try{
                Teacher teacher = new Teacher();
                teacher.Register(new Bell());
                Student student = new Student();
                student.Register(new Bell());
                Console.ReadKey();
            }
            catch(Exception ex)
            {
                Console.WriteLine(ex.Message);
            }
        }
    }
}

输入

无输入

输出

验证事件输出 

样例输入

样例输出

teacher
student
using System;
using System.Collections.Generic;
using System.Linq;
using System.Text;
using System.Threading.Tasks;
using System.Security.Cryptography;
using System.IO;
namespace ConsoleApplication1
{
    public delegate void DelegateRing();
    public class Bell
    {
        public event DelegateRing Ring;
        public void OnRing() { Ring(); }
    }
    class Teacher
    {
        public void Register(Bell bell)
        {
            bell.Ring += new DelegateRing(HandleEvent);
            bell.OnRing();
        }
        public void HandleEvent()
        {
            Console.WriteLine("teacher");
        }
    }
    class Student
    {
        public void Register(Bell bell)
        {
            bell.Ring += new DelegateRing(HandleEvent2);
            bell.OnRing();
        }
        public void HandleEvent2()
        {
            Console.WriteLine("student");
        }
    }
    class Program
    {
        static void Main(string[] args)
        {
            try
            {
                Teacher teacher = new Teacher();
                teacher.Register(new Bell());
                Student student = new Student();
                student.Register(new Bell());
                Console.ReadKey();
            }
            catch (Exception ex)
            {
                Console.WriteLine(ex.Message);
            }
        }
    }
} 
  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值