Vawio Sequence

算法:动态规划

描述
Vawio Sequence is very funny,it is a sequence of integers. It has some interesting properties.
· Vawio is of odd length i.e. L = 2*n + 1.
· The first (n+1) integers of Vawio sequence makes a strictly increasing sequence.
· The last (n+1) integers of Vawio sequence makes a strictly decreasing sequence.
· No two adjacent integers are same in a Vawio sequence.
For example 1, 2, 3, 4, 5, 4, 3, 2, 0 is an Vawio sequence of length 9. But 1, 2, 3, 4, 5, 4, 3, 2, 2 is not a valid Vawio sequence. In this problem, you will be given a sequence of integers. You have to find out the length of the longest Vawio sequence which is a subsequence of the given sequence. Consider, the given sequence as :

1 2 3 2 1 2 3 4 3 2 1 5 4 1 2 3 2 2 1.

Here the longest Wavio sequence is : 1 2 3 4 5 4 3 2 1. So, the output will be 9.
输入
The input file contains less than 75 test cases. The description of each test case is given below: Input is terminated by end of file.

Each set starts with a postive integer, N(1<=N<=10000). In next few lines there will be N integers
输出
For each set of input print the length of longest Vawio sequence in a line.
样例输入
10
1 2 3 4 5 4 3 2 1 10
19
1 2 3 2 1 2 3 4 3 2 1 5 4 1 2 3 2 2 1
5
1 2 3 4 5
样例输出
9
9
1

代码:

/*二分法,单调子序列两次; 
nyoj Vawio Sequence

#include <iostream>
#include <cstring>
#include <string>
#include <iomanip>
#include <algorithm>
#include <queue>
#include <stdio.h>
using namespace std;
int dp[10005],dp1[10005],map[10005];
int map1[10005];
int len;
int serch(int x)
{
	int l=0,r=len;
	while(l<=r)
	{
		int mid=(l+r)/2;
		if(x==map1[mid]) return mid;
		if(x<map1[mid]) r=mid-1;
		else l=mid+1;
	}
	return l;
}
int main()
{
	int i,j,k,m,n;
	while(scanf("%d",&n)!=EOF)
	{
		for(i=1;i<=n;i++)
		{
			cin>>map[i];
			dp[i]=dp1[i]=1;
		}
		map1[0]=map[1];
		len=0;
		dp[1]=1;
		for(i=1;i<=n;i++)
		{
			k=serch(map[i]);
			map1[k]=map[i];
			dp[i]=k+1;
			if(k>len) len=k;
		}
		len=0;
		map1[0]=map[n];
		dp1[n]=1;
		int ans=0,temp=0;
		for(i=n;i>0;i--)
		{
			k=serch(map[i]);
			map1[k]=map[i];
			dp1[i]=k+1;
			if(k>len) len=k;
			ans=min(dp1[i],dp[i]);
			temp=max(2*ans-1,temp);
		}
		cout<<temp<<endl;
	}
	return 0;
} 
*/ 


  • 0
    点赞
  • 1
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值