nyoj Vawio Sequence 763 (STL) LIS变型

Vawio Sequence

时间限制: 1000 ms  |           内存限制: 65535 KB
难度: 3
描述
Vawio Sequence is very funny,it is a sequence of integers. It has some interesting properties.
·   Vawio is of odd length i.e. L = 2*n + 1.
·  The first (n+1) integers of  Vawio sequence makes a strictly increasing sequence.
·  The last (n+1) integers of  Vawio sequence makes a strictly decreasing sequence.
·  No two adjacent integers are same in a  Vawio sequence.
For example 1, 2, 3, 4, 5, 4, 3, 2, 0 is an  Vawio sequence of length 9. But 1, 2, 3, 4, 5, 4, 3, 2, 2 is not a valid  Vawio sequence. In this problem, you will be given a sequence of integers. You have to find out the length of the longest  Vawio sequence which is a subsequence of the given sequence. Consider, the given sequence as :

1 2 3 2 1 2 3 4 3 2 1 5 4 1 2 3 2 2 1.

Here the longest Wavio sequence is : 1 2 3 4 5 4 3 2 1. So, the output will be 9.
输入
The input file contains less than 75 test cases. The description of each test case is given below: Input is terminated by end of file.

Each set starts with a postive integer, N(1<=N<=10000). In next few lines there will be N integers
输出
For each set of input print the length of longest  Vawio sequence in a line.
样例输入
10
1 2 3 4 5 4 3 2 1 10
19
1 2 3 2 1 2 3 4 3 2 1 5 4 1 2 3 2 2 1
5
1 2 3 4 5
样例输出
9
9
1
//看了大神的才知还可以这样解,我一开始是用LIS写的,但超时。。。
//AC代码
#include<stdio.h>
#include<string.h>
#include<algorithm>
#define N 10010
using namespace std;
int a[N];
int l[N];
int r[N];
int dp[N];
int main()
{
	int n,i,j,k;
	while(scanf("%d",&n)!=EOF)
	{
		memset(dp,0x3f3f3f,sizeof(dp));
		for(i=0;i<n;i++)
			scanf("%d",&a[i]);
		for(i=0;i<n;i++)
		{
			k=lower_bound(dp,dp+n,a[i])-dp;
			dp[k]=a[i];
			l[i]=k+1;
		}
		memset(dp,0x3f3f3f,sizeof(dp));
		for(i=n-1;i>=0;i--)
		{
			k=lower_bound(dp,dp+n,a[i])-dp;
			dp[k]=a[i];
			r[i]=k+1;
		}
		int ans=0;
		for(i=0;i<n;i++)
			ans=max(ans,min(l[i],r[i]));
		printf("%d\n",2*ans-1);
	}
	return 0;
}

//我的LIS超时。。
#include<stdio.h>
#include<string.h>
#include<algorithm>
#define INF 0x3f3f3f
#define N 10010
using namespace std;
int a[N];
int b[N];
int c[N];
int main()
{
	int n,i,j;
	while(scanf("%d",&n)!=EOF)
	{
		
		for(i=0;i<n;i++)
			scanf("%d",&a[i]);
		for(i=0;i<n;i++)
		{
			b[i]=1;
			c[i]=1;
		}
		for(i=n-2;i>=0;i--)
		{
			for(j=i+1;j<n;j++)
			{
				if(a[i]<a[j]&&b[i]<b[j]+1)
					b[i]=b[j]+1;
				if(a[i]>a[j]&&c[i]<c[j]+1)
					c[i]=c[j]+1;
			}
		}
		int mm1=0,mm2=0;
		for(i=0;i<n;i++)
		{
			mm1=max(mm1,b[i]);
			mm2=max(mm2,c[i]);
		}
		printf("%d\n",2*min(mm1,mm2)-1);
	}
	return 0;
}

  • 0
    点赞
  • 1
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值