ZOJ_1049_I Think I Need a Houseboat

I Think I Need a Houseboat

Time Limit: 2 Seconds       Memory Limit: 65536 KB

Fred Mapper is considering purchasing some land in Louisiana to build his house on. In the process of investigating the land, he learned that the state of Louisiana is actually shrinking by 50 square miles each year, due to erosion caused by the Mississippi River. Since Fred is hoping to live in this house the rest of his life, he needs to know if his land is going to be lost to erosion. 

After doing more research, Fred has learned that the land that is being lost forms a semicircle. This semicircle is part of a circle centered at (0,0), with the line that bisects the circle being the X axis. Locations below the X axis are in the water. The semicircle has an area of 0 at the beginning of year 1. (Semicircle illustrated in the Figure.)


Input Format: 

The first line of input will be a positive integer indicating how many data sets will be included (N). 

Each of the next N lines will contain the X and Y Cartesian coordinates of the land Fred is considering. These will be floating point numbers measured in miles. The Y coordinate will be non-negative. (0,0) will not be given.


Output Format: 

For each data set, a single line of output should appear. This line should take the form of: 

��Property N: This property will begin eroding in year Z.�� 

Where N is the data set (counting from 1), and Z is the first year (start from 1) this property will be within the semicircle AT THE END OF YEAR Z. Z must be an integer. 

After the last data set, this should print out ��END OF OUTPUT.��

Notes: 

1. No property will appear exactly on the semicircle boundary: it will either be inside or outside. 

2. This problem will be judged automatically. Your answer must match exactly, including the capitalization, punctuation, and white-space. This includes the periods at the ends of the lines.

3. All locations are given in miles. 


Sample Input: 


1.0 1.0 
25.0 0.0 


Sample Output: 

Property 1: This property will begin eroding in year 1. 
Property 2: This property will begin eroding in year 20. 
END OF OUTPUT.




题意:首先看图,每年腐蚀50平方米的面积(比如第i年就腐蚀i*50平方米也就是半圆的面积),Fred的房子在X轴上方的某点,问第几年会腐蚀到,实际上就是问i为什么值得时候Fred的房子坐标(x,y)落入半圆中

思路:就是一数学题,是否在半圆内用距离公式判断就可以了。话说看英文一开始理解题意花了我点时间。。英语也要提高啊。。


Sample program Here

#include<iostream>
#include<math.h>
using namespace std;
const double PI=3.14159;
int main(){
  int n;//表示几组数据
  int r2; //表示半径的平方
  int d2;//表示坐标到原点的距离的平方
  float x,y;
  cin>>n;
  for(int i=0;i<n;i++){
	 int j=1;//用于计数,表示年数
     cin>>x>>y;
	 while(1){
	   r2=(j*100)/PI; //第j年半径的平方
	   d2=pow(x,2)+pow(y,2);
       if( d2<r2 )  break;
	   else j++;	 
	 }
	 cout<<"Property "<<i+1<<": This property will begin eroding in year "<<j<<"."<<endl;
  }

  cout<<"END OF OUTPUT."<<endl;
  return 0;
}




评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值