ZOJ_1242_Carbon Dating

Carbon Dating

Time Limit: 2 Seconds       Memory Limit: 65536 KB

Until the second half of the 20th century, determining the actual age of an archaeological find had been more or less a matter of educated guessing. Comparing finds to previous, already dated, ones and evaluation of the surroundings of a find were the best available techniques.

But nowadays, there is a much more reliable method: carbon dating. Carbon dating works as follows: Naturally occurring carbon is a mixture of stable isotope (mostly 12C) and the unstable, radioactive, isotope 14C. The ratio between the two is almost constant in living organisms: 14C slowly decays, but at the same time, the radiation of the sum produces the same amount in the upper atmosphere, which is taken in by the organisms.

But when, for example, a tree is felled and made to wood, it does not receive any new 14C, and the amount present in the wood becomes less and less due to radioactive decay. In this problem, you are to write a program that uses information about the amount of remaining 14C to determine the approximate age of sample. The following facts must be used:

The amount of 14C present in a sample halves every 5730 years (this is called the half-life of 14C).

The rate of decay (measured in decays per hour per gram of carbon) is proportional to the amount of 14C left in the sample.

In living organisms (age zero), there are 810 decays per hour per gram of carbon.

So, for example, if we measure in a sample of one gram of carbon 405 decays per hour, we know that it is approximately 5730 years old.

Input

The input contains the measurements taken of several samples we want to date. Every line contains two positive integers, w and d. w is the amount of carbon in the sample, measured in grams, and d is the number of decays measured over one hour.

The input is terminated by a test case starting with w = d = 0.


Output

For each sample description in the input, first output the numnber of the sample, as shown in the sample output.Then print the approximate age in the format

The approximate age is x years.

If the age is less than 10,000 years, x should be rounded to the colsest multiple of 100 years (rounding up in case of a tie). If the age is more than 10,000 years, round it to the closest multiple of 1000 years (again rounding up in case of a tie).

Print a blank line after each sample.


Sample Input

1 405
5 175
0 0


Sample Output

Sample #1
The approximate age is 5700 years.

Sample #2
The approximate age is 26000 years.


题意和思路:关键是如何得到year的关系式,具体的推导方法我已经在代码中用注释写出。其他地方就没什么困难了
/******************************************
**
**      Author: Wan KaiMing
**      Date:   2012-11-02-20.43 星期五
**
*******************************************/



/*
*
*
*设原本的质量M 经过t年后剩余的为m
* 衰变的速度为d/w
* 有题意知衰变速度和剩余的质量成正比 kd/w=m 又特殊值405的衰变速度为1g得到系数k=1/405
* 又因为810的衰变速度是质量为M的时候的速度得到 快k*810=m 所以M=2
* 由5730年c14减少一半列出等式
*  M*( (1/2)^(t/5730) ) = m = kd/w =d/(405*w)
* 代入数据经化简得到具体的t=5730*log2 (810*w/d+0.0);   其中2是log底数用空格隔开
*/
#include<iostream>
#include<string>
#include<cmath>
using namespace std;
int main(){
   double w=0,d=0;//decays表示每克的衰变数,注意是每克
   int count=0;
   while(cin>>w>>d){
      if(w==0&&d==0) break;
      cout<<"Sample #"<<++count<<endl;
      int year=5730*log(810*w/d+0.0)/log(2.0);
      if(year<10000){
          year+=50;  //year+=50主要为了四舍五入
          year/=100;
          year*=100;
      }
      else {
          year+=500;  //为了四舍五入
          year/=1000;
          year*=1000;
      }

      cout<<"The approximate age is "<<year<<" years."<<endl<<endl;

   }
   return 0;
}


  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值