1292_Integer Inquiry(有小问题,未能通过)

One of the first users of BIT's new supercomputer was Chip Diller. He extended his exploration of powers of 3 to go from 0 to 333 and he explored taking various sums of those numbers.

``This supercomputer is great,'' remarked Chip. ``I only wish Timothy were here to see these results.'' (Chip moved to a new apartment, once one became available on the third floor of the Lemon Sky apartments on Third Street.)


Input

The input will consist of at most 100 lines of text, each of which contains a single VeryLongInteger. Each VeryLongInteger will be 100 or fewer characters in length, and will only contain digits (no VeryLongInteger will be negative).

The final input line will contain a single zero on a line by itself.


Output

Your program should output the sum of the VeryLongIntegers given in the input.


This problem contains multiple test cases!

The first line of a multiple input is an integer N, then a blank line followed by N input blocks. Each input block is in the format indicated in the problem description. There is a blank line between input blocks.

The output format consists of N output blocks. There is a blank line between output blocks.


Sample Input

1

123456789012345678901234567890
123456789012345678901234567890
123456789012345678901234567890
0


Sample Output

370370367037037036703703703670

********************************************************************

#include<iostream>
#include<string>
#include<vector>
using namespace std;
int main()
{
string s1,s2;
string s3("0123456789");
int c;//进位
vector<int> v1;
int n;
int test=0;
cin>>n;
cout<<endl;
for(int m=0;m!=n;m++)
{
v1.clear();
c=0;//这两个初始化很恨重要!困扰了一晚上
cin>>s1;
if(s1=="0")
v1.push_back(s1[0]-48);//s1[0]-48非s[0]
else
{
for(int i=0;i!=s1.size();++i)
{
s1[i]-=48;
v1.push_back(s1[i]);
}


while(cin>>s2&&s2!="0")
{
if(v1.size()==s2.size())
for(int i=v1.size()-1;i>=0;--i)
{
s2[i]-=48;
v1[i]=v1[i]+s2[i]+c;
if(v1[i]>=10)
{
c=1;
v1[i]-=10;
}
else
c=0;
}


if(v1.size()<s2.size())
{   
int num=s2.size()-v1.size();
vector<int>::iterator iter=v1.begin();
for(int i=0;i!=num;++i)
{   
v1.insert(iter,0);
iter=v1.begin();
}
//for(int i=0;i!=s2.size()-v1.size();++i)
//{   
// v1.insert(iter,0);
//  iter=v1.begin();
//}//这个循环错误,因为v1大小变化,而循环条件中用到v1的大小
for(int i=v1.size()-1;i>=0;--i)
{
s2[i]-=48;
v1[i]=v1[i]+s2[i]+c;
if(v1[i]>=10)
{
c=1;
v1[i]-=10;
}
else
c=0;
}
}
if(v1.size()>s2.size())
{
int num=v1.size()-s2.size();
for(int i=0;i!=num;++i)
s2.insert( 0,"0");
for(int i=v1.size()-1;i>=0;--i)
{
s2[i]-=48;
v1[i]=v1[i]+s2[i]+c;
if(v1[i]>=10)
{
c=1;
v1[i]-=10;
}
else
c=0;
}
}
if(c==1)
{
vector<int>::iterator iter=v1.begin();
v1.insert(iter,1);
}
}
}
c=0;
if(v1.size()==1)
cout<<s3[v1[0]];
else
{
for(vector<int>::iterator iter=v1.begin();iter!=v1.end();++iter)
if(*iter==0)
++test;
if(test==v1.size())
cout<<0;
else
for(vector<int>::iterator iter=v1.begin();iter!=v1.end();++iter)
{
if(*iter==0&&c==0)
continue;
else
{
cout<<*iter;
c=1;
}
}
}
cout<<endl;

cout<<endl;
}
return 0;
}








  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值