Photo List(poj3630,Trid字典树的运用)

Phone List

Time Limit: 1000MS Memory Limit: 65536K
Total Submissions: 33616 Accepted: 9698

Description

Given a list of phone numbers, determine if it is consistent in the sense that no number is the prefix of another. Let's say the phone catalogue listed these numbers:

  • Emergency 911
  • Alice 97 625 999
  • Bob 91 12 54 26

In this case, it's not possible to call Bob, because the central would direct your call to the emergency line as soon as you had dialled the first three digits of Bob's phone number. So this list would not be consistent.

Input

The first line of input gives a single integer, 1 ≤ t ≤ 40, the number of test cases. Each test case starts with n, the number of phone numbers, on a separate line, 1 ≤ n ≤ 10000. Then follows n lines with one unique phone number on each line. A phone number is a sequence of at most ten digits.

Output

For each test case, output "YES" if the list is consistent, or "NO" otherwise.

Sample Input

2
3
911
97625999
91125426
5
113
12340
123440
12345
98346

Sample Output

NO
YES

Source

Nordic 2007

 

【解析】

就是Trie字典树的运用,一开始反应了老半天,原来题目还有个坑点就是如果是前缀的话输出NO,否则输出YES。。。。

我说样例怎么不太对。

此处需要边插入边判断,如果现在插入的值之前不需要另外加入结点了,那么说明现在的就是前缀了,如果经过了某个有标记的结点那么前面就是现在的前缀了。

#include <bits/stdc++.h>
using namespace std;
const int N = 1e4 + 10;
const int Z = 10;

int tot;
int ch[N][Z];
bool bo[N];

void clear()
{
	memset(ch, 0, sizeof(ch));
	memset(bo, 0, sizeof(bo));
}

bool insert(char *s)
{
	int len = strlen(s);
	int u = 1;
	bool flag = 0;
	for (int i = 0; i < len; i++)
	{
		int c = s[i] - '0';
		if (!ch[u][c])
			ch[u][c] = ++tot;
		else if (i == len - 1)
			flag = 0;
		u = ch[u][c];
		if (bo[u])flag = 1;
	}
	bo[u] = 1;
	return flag;
}

int main()
{
	int t;
	scanf("%d", &t);
	while (t--)
	{
		int n;
		scanf("%d", &n);
		tot = 1;
		clear();
		bool ans = 0;
		for (int i = 0; i < n; i++)
		{
			char s[20];
			scanf("%s", s);
			if (insert(s))ans = 1;
		}
		printf("%s\n", ans ? "NO" : "YES");
	}

	return 0;
}

 

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值