D - Mad Scientist (打表模拟)

A mad scientist performed a series of experiments, each having n phases. During each phase, a measurement was taken, resulting in a positive integer of magnitude at most k. The scientist knew that an individual experiment was designed in a way such that its measurements were monotonically increasing, that is, each measurement would be at least as big as all that precede it. For example, here is a sequence of measurements for one such experiment with n = 13 and k = 6:

1, 1, 2, 2, 2, 2, 2, 4, 5, 5, 5, 5, 6

It was also the case that n was to be larger than k, and so there were typically many repeated values in the measurement sequence. Being mad, the scientist chose a somewhat unusual way to record the data. Rather than record each of n measurements, the scientist recorded a sequence P of k values defined as follows. For 1 ≤ j ≤ k, P(j) denoted the number of phases having a measurement of j or less. For example, the original measurements from the above experiment were recorded as the P-sequence:

2, 7, 7, 8, 12, 13

as there were two measurements less than or equal to 1, seven measurements less than or equal to 2, seven measurement less than or equal to 3, and so on. Unfortunately, the scientist eventually went insane, leaving behind a notebook of these P-sequences for a series of experiments. Your job is to write a program that recovers the original measurements for the experiments.

Input

The input contains a series of P-sequences, one per line. Each line starts with the integer k, which is the length of the P-sequence. Following that are the k values of the P-sequence. The end of the input will be designated with a line containing the number ‘0’. All of the original experiments were designed with 1 ≤ k < n ≤ 26.

Output

For each P-sequence, you are to output one line containing the original experiment measurements separated by spaces.

Sample Input

6 2 7 7 8 12 13

1 4

3 4 4 5

3 0 4 5

5 2 2 4 7 7

0

Sample Output

1 1 2 2 2 2 2 4 5 5 5 5 6

1 1 1 1

1 1 1 1 3

2 2 2 2 3

1 1 3 3 4 4 4

 

【解析】

题意:科学家用特殊的方法记录实验数据,让你还原成普通的数据。

每行第一个数据为n,之后n个值,对第i个,表示小于i的数据有几个

比如序列 n = 6   2, 7, 7, 8, 12, 13

还原后为1 1 2 2 2 2 2 4 5 5 5 5 6

最后输出的一个数据没有空格

#include <bits/stdc++.h>
using namespace std;
int main()
{
	int n;
	int s[1010] = { 0 };
	int ans[1010];
	while (~scanf("%d", &n))
	{
		if (n == 0)break;
		for (int i = 1; i <= n; i++)scanf("%d", &s[i]);
		int k = 0;
		for (int i = 1; i <= n; i++)
			for (int j = 0; j < s[i] - s[i - 1]; j++)
				ans[k++] = i;
		printf("%d", ans[0]);
		for (int i = 1; i < k; i++)
			printf(" %d", ans[i]);
		printf("\n");
	}
	return 0;
}

 

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值