Mad Scientist(规律)

Description

  A mad scientist performed a series of experiments, each having n phases. During each phase, a measurement was taken, resulting in a positive integer of magnitude at most k. The scientist knew that an individual experiment was designed in a way such that its measurements were monotonically increasing, that is, each measurement would be at least as big as all that precede it. For example, here is a sequence of measurements for one such experiment with n = 13 and k = 6:

                                                                     1, 1, 2, 2, 2, 2, 2, 4, 5, 5, 5, 5, 6

  It was also the case that n was to be larger than k, and so there were typically many repeated values in the measurement sequence. Being mad, the scientist chose a somewhat unusual way to record the data. Rather than record each of n measurements, the scientist recorded a sequence P of k values defined as follows. For 1 ≤ j ≤ k, P(j) denoted the number of phases having a measurement of j or less. For example, the original measurements from the above experiment were recorded as the P-sequence:

                                                                                2, 7, 7, 8, 12, 13

  as there were two measurements less than or equal to 1, seven measurements less than or equal to 2, seven measurement less than or equal to 3, and so on.

  Unfortunately, the scientist eventually went insane, leaving behind a notebook of these P-sequences for a series of experiments. Your job is to write a program that recovers the original measurements for the experiments.

Input

  The input contains a series of P-sequences, one per line. Each line starts with the integer k, which is the length of the P-sequence. Following that are the k values of the P-sequence. The end of the input will be designated with a line containing the number ‘0’. All of the original experiments were designed with 1 ≤ k < n ≤ 26.

Output

  For each P-sequence, you are to output one line containing the original experiment measurements separated by spaces.

Sample Input

6 2 7 7 8 12 13

1 4

3 4 4 5

3 0 4 5

5 2 2 4 7 7

0

Sample Output

1 1 2 2 2 2 2 4 5 5 5 5 6

1 1 1 1

1 1 1 1 3

2 2 2 2 3

1 1 3 3 4 4 4

解析

  通过观察样例发现,输出的都是有序的自然数(有重复),而个数与读入的数据有关。例如样例一,读入6个数据 2 7 7 8 12 13。

而输出中1的个数=2,2的个数=7-2=5,3的个数=7-7=0,4的个数=8-7=1,5的个数=12-8=4,6的个数=13-12=1。

代码

#include<stdio.h>
int main()
{
    int n,i,j,p[30];
    while(~scanf("%d",&n))
    {
        if(n==0) break;
        int num[30]={0};
        for(i=1;i<=n;i++)
        {
            scanf("%d",&p[i]);
        }
        p[0]=0;
        for(i=1;i<=n;i++)
        {
            num[i]=p[i]-p[i-1];
        }
        int flag=0;
        for(i=1;i<=26;i++)
        {
          if(num[i]!=0)
          {
             for(j=1;j<=num[i];j++)
             {
                if(!flag)
                {
                   printf("%d",i);
                   flag=1;
                }
                else
                    printf(" %d",i);
             }
          }
        }
        printf("\n");
    }
    return 0;
}

 

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
提供的源码资源涵盖了安卓应用、小程序、Python应用和Java应用等多个领域,每个领域都包含了丰富的实例和项目。这些源码都是基于各自平台的最新技术和标准编写,确保了在对应环境下能够无缝运行。同时,源码中配备了详细的注释和文档,帮助用户快速理解代码结构和实现逻辑。 适用人群: 这些源码资源特别适合大学生群体。无论你是计算机相关专业的学生,还是对其他领域编程感兴趣的学生,这些资源都能为你提供宝贵的学习和实践机会。通过学习和运行这些源码,你可以掌握各平台开发的基础知识,提升编程能力和项目实战经验。 使用场景及目标: 在学习阶段,你可以利用这些源码资源进行课程实践、课外项目或毕业设计。通过分析和运行源码,你将深入了解各平台开发的技术细节和最佳实践,逐步培养起自己的项目开发和问解决能力。此外,在求职或创业过程中,具备跨平台开发能力的大学生将更具竞争力。 其他说明: 为了确保源码资源的可运行性和易用性,特别注意了以下几点:首先,每份源码都提供了详细的运行环境和依赖说明,确保用户能够轻松搭建起开发环境;其次,源码中的注释和文档都非常完善,方便用户快速上手和理解代码;最后,我会定期更新这些源码资源,以适应各平台技术的最新发展和市场需求。

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值