Mad Scientist(规律)

Description

  A mad scientist performed a series of experiments, each having n phases. During each phase, a measurement was taken, resulting in a positive integer of magnitude at most k. The scientist knew that an individual experiment was designed in a way such that its measurements were monotonically increasing, that is, each measurement would be at least as big as all that precede it. For example, here is a sequence of measurements for one such experiment with n = 13 and k = 6:

                                                                     1, 1, 2, 2, 2, 2, 2, 4, 5, 5, 5, 5, 6

  It was also the case that n was to be larger than k, and so there were typically many repeated values in the measurement sequence. Being mad, the scientist chose a somewhat unusual way to record the data. Rather than record each of n measurements, the scientist recorded a sequence P of k values defined as follows. For 1 ≤ j ≤ k, P(j) denoted the number of phases having a measurement of j or less. For example, the original measurements from the above experiment were recorded as the P-sequence:

                                                                                2, 7, 7, 8, 12, 13

  as there were two measurements less than or equal to 1, seven measurements less than or equal to 2, seven measurement less than or equal to 3, and so on.

  Unfortunately, the scientist eventually went insane, leaving behind a notebook of these P-sequences for a series of experiments. Your job is to write a program that recovers the original measurements for the experiments.

Input

  The input contains a series of P-sequences, one per line. Each line starts with the integer k, which is the length of the P-sequence. Following that are the k values of the P-sequence. The end of the input will be designated with a line containing the number ‘0’. All of the original experiments were designed with 1 ≤ k < n ≤ 26.

Output

  For each P-sequence, you are to output one line containing the original experiment measurements separated by spaces.

Sample Input

6 2 7 7 8 12 13

1 4

3 4 4 5

3 0 4 5

5 2 2 4 7 7

0

Sample Output

1 1 2 2 2 2 2 4 5 5 5 5 6

1 1 1 1

1 1 1 1 3

2 2 2 2 3

1 1 3 3 4 4 4

解析

  通过观察样例发现,输出的都是有序的自然数(有重复),而个数与读入的数据有关。例如样例一,读入6个数据 2 7 7 8 12 13。

而输出中1的个数=2,2的个数=7-2=5,3的个数=7-7=0,4的个数=8-7=1,5的个数=12-8=4,6的个数=13-12=1。

代码

#include<stdio.h>
int main()
{
    int n,i,j,p[30];
    while(~scanf("%d",&n))
    {
        if(n==0) break;
        int num[30]={0};
        for(i=1;i<=n;i++)
        {
            scanf("%d",&p[i]);
        }
        p[0]=0;
        for(i=1;i<=n;i++)
        {
            num[i]=p[i]-p[i-1];
        }
        int flag=0;
        for(i=1;i<=26;i++)
        {
          if(num[i]!=0)
          {
             for(j=1;j<=num[i];j++)
             {
                if(!flag)
                {
                   printf("%d",i);
                   flag=1;
                }
                else
                    printf(" %d",i);
             }
          }
        }
        printf("\n");
    }
    return 0;
}

 

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
欧莱雅是一家全球知名的美妆品牌,在其公司的面试过程中,对于欧莱雅 data scientist 而言,以下是一些可能的问和回答。 首先,面试官可能会询问有关数据分析和数据科学的技术和方法的问。作为 data scientist,我会强调数据清洗和处理的重要性,以及使用统计分析和机器学习算法来揭示数据背后的价值和潜在趋势。我还会强调熟悉一些常用的数据科学工具和编程语言,如Python和R。 其次,面试官可能会询问与欧莱雅业务相关的问。作为 data scientist,我会着重强调与美妆行业相关的数据分析经验和见解。我会提到我如何分析顾客购买习惯,挖掘潜在的消费趋势,并提供个性化的产品建议。我还会强调我对消费者行为和市场趋势的敏感度,以及判断和预测顾客需求的能力。 此外,面试官可能会问到我的团队合作和沟通能力。作为 data scientist,在团队合作中,我会强调我与团队成员之间的有效沟通和协作,以及我的能力将复杂的数据科学问解释给非技术人员。我相信与业务团队和其他相关部门的密切合作是实现数据驱动决策的关键。 最后,我还会强调我的学习能力和自我发展的能力。作为 data scientist,我意识到数据科学领域不断发展和更新的速度。我会提到我保持对业界最新趋势的关注,并参加学术会议和培训课程以扩展我的知识和技能。 综上所述,面试是一个展示自己技能和经验的机会。作为欧莱雅 data scientist 候选人,我会强调我的数据分析和数据科学技术,与美妆行业相关的经验和见解,以及团队合作和沟通能力。我也会强调我的学习能力和持续发展的态度。
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值