hdu 5778 abs

Problem Description
Given a number x, ask positive integer  y2 , that satisfy the following conditions:
1. The absolute value of y - x is minimal
2. To prime factors decomposition of Y, every element factor appears two times exactly.
 

Input
The first line of input is an integer T (  1T50 )
For each test case,the single line contains, an integer x (  1x1018 )
 

Output
For each testcase print the absolute value of y - x
 

Sample Input
  
  
5 1112 4290 8716 9957 9095
 

Sample Output
  
  
23 65 67 244 70
由于y质因数分解式中每个质因数均出现2次,那么y是一个完全平方数,设y=z*z,题目可转换成求z,使得每个质因数出现1次. 我们可以暴力枚举z,检查z是否符合要求,显然当z是质数是符合要求,由素数定理可以得,z的枚举量在logn级别 复杂度 O( \sqrt[4]{n}log\sqrt[2]{n}4nlog2n

#include<stdio.h>
#include<algorithm>
#include<iostream>
#include<cmath>
#define ll long long
using namespace std;
ll Abs(ll x){
   if(x<0)  return -x;
   return x;
}
bool judge(ll x){
    for(ll i=2;i*i<=x;i++){//printf("%lld ",i);
        int ans=0;
        while(1){
            if(x%i==0){
                ans++;x/=i;
            }
            else break;
            if(ans>=2) return false;
        }
    }//printf("%I64d~~~\n",x);
    return true;
}
ll b[]={0,3,2,1,0,1,2,2,1,0};
int main(){
    int T;
    scanf("%d",&T);
    while(T--){
        ll n,i,j,ans=9999999999;
        bool flag=false;
        scanf("%I64d",&n);
        ll s=sqrt(n);
        i=s;j=s+1;
        //judge(1089);
        if(n<=9)
            ans=b[n];
        else
            while(1){
                if(!judge(i)) i--;
                else {
                    ans=min(ans,Abs(i*i-n));flag=true;
                }
                if(!judge(j)) j++;
                else{
                    ans=min(ans,Abs(j*j-n));flag=true;
                }
                if(flag) break;
            }//printf("%I64d %d %I64d %d\n",i,judge(i),j,judge(j));
        printf("%lld\n",ans);
    }
    return 0;
}


评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值