洛谷刷题 | P1014 [NOIP1999 普及组] Cantor 表

[NOIP1999 普及组] Cantor 表

题目描述

现代数学的著名证明之一是 Georg Cantor 证明了有理数是可枚举的。他是用下面这一张表来证明这一命题的:

我们以 Z 字形给上表的每一项编号。第一项是 1 / 1 1/1 1/1,然后是 1 / 2 1/2 1/2 2 / 1 2/1 2/1 3 / 1 3/1 3/1 2 / 2 2/2 2/2,…

输入格式

整数 N N N 1 ≤ N ≤ 1 0 7 1 \leq N \leq 10^7 1N107)。

输出格式

表中的第 N N N 项。

样例 #1

样例输入 #1

7

样例输出 #1

1/4
#include<stdio.h>
#include<stdlib.h>
#include<string.h>
#include<math.h>
#include<stdbool.h>

#define Pi 3.14
#define MAX 99999

int main(){
	int n,ans_x,ans_y;
	int i,j;
	scanf("%d",&n);
	if(n==1){
		printf("1/1");
		return 0;
	}
	else{
		int count=2;
	    int x=0,y=0;
	    for(i=1;i<n;i++){
	        x=i;     //每轮为一行
	        y=0;
	        if(i%2!=0){	  
	        	while(x>=0){	        
		        	if(n==count){
		        		ans_x = y + 1;
		        		ans_y = x + 1;
						printf("%d/%d",ans_x,ans_y);
						return 0;
					}
		            count++;
		            x--;//斜着赋值
		            y++;
	        	}    
			        x=0;
			        y=0;
			}
			else{
				while(x>=0){
		        	if(n==count){
		        		ans_x = x + 1;
		        		ans_y = y + 1;
						printf("%d/%d",ans_x,ans_y);
						return 0;
					}
		        	count++;
		        	x--;//斜着赋值
		            y++;
				}
				    x=0;
			        y=0;
			}
	    }
	}
	return 0;
}
  • 17
    点赞
  • 6
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值