Billboard(线段树+更新节点+询问特殊)

Billboard

Time Limit: 20000/8000 MS (Java/Others)    Memory Limit: 32768/32768 K (Java/Others)
Total Submission(s): 26780    Accepted Submission(s): 10937


Problem Description
At the entrance to the university, there is a huge rectangular billboard of size h*w (h is its height and w is its width). The board is the place where all possible announcements are posted: nearest programming competitions, changes in the dining room menu, and other important information.

On September 1, the billboard was empty. One by one, the announcements started being put on the billboard.

Each announcement is a stripe of paper of unit height. More specifically, the i-th announcement is a rectangle of size 1 * wi.

When someone puts a new announcement on the billboard, she would always choose the topmost possible position for the announcement. Among all possible topmost positions she would always choose the leftmost one.

If there is no valid location for a new announcement, it is not put on the billboard (that's why some programming contests have no participants from this university).

Given the sizes of the billboard and the announcements, your task is to find the numbers of rows in which the announcements are placed.
 

Input
There are multiple cases (no more than 40 cases).

The first line of the input file contains three integer numbers, h, w, and n (1 <= h,w <= 10^9; 1 <= n <= 200,000) - the dimensions of the billboard and the number of announcements.

Each of the next n lines contains an integer number wi (1 <= wi <= 10^9) - the width of i-th announcement.
 

Output
For each announcement (in the order they are given in the input file) output one number - the number of the row in which this announcement is placed. Rows are numbered from 1 to h, starting with the top row. If an announcement can't be put on the billboard, output "-1" for this announcement.
 

Sample Input
 
 
3 5 524333
 

Sample Output
 
 
1213-1

具体题解点这里

#include <iostream>
#include <string.h>
#define max(x,y) x>y?x:y
#define size 200010 << 2
using namespace std;
//int tree[size]; // 线段树
int* tree;
int h, w, n;

// 更新节点值
void PushUp(int p) {
	tree[p] = max(tree[p * 2], tree[p * 2 + 1]);
}

// 构造函数
void Build(int l, int r, int p) {
	if (l == r) {
		tree[p] = w;
		return;
	}
	int m = (l + r) / 2;
	Build(l, m, p * 2);
	Build(m + 1, r, p * 2 + 1);
	PushUp(p);
}

// 区域操作
void Update(int C, int l, int r, int p) {
	if (l == r) {
		tree[p] -= C;
		printf("%d\n", l);
		return;
	}

	int m = (l + r) / 2;
	if (tree[p * 2] >= C)
		Update(C, l, m, p * 2);
	else if (tree[p * 2 + 1] >= C)
		Update(C, m + 1, r, p * 2 + 1);
	PushUp(p);
}

int main() {
	//freopen("1.txt", "r", stdin);
	while (scanf("%d %d %d", &h, &w, &n) == 3) {
		// 这里h比n大的部分不需要,所以如果h比n大,那么h设定为n就好
		if (h > n)
			h = n;
		// 树的2种大小申请方式,4倍大小的申请方式实测比固定大小的(200000 << 2) 大10倍
		tree = new int[h * 4]; 
		//memset(tree, 0, size);
		Build(1, h, 1);
		while (n--) {
			int C;
			scanf("%d", &C);
			if (tree[1] >= C)
				Update(C, 1, h, 1);
			else
				printf("-1\n");
		}
	}
	return 0;
}
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值