HDU 3613 Best Reward (Manacher变形)

Problem Description

After an uphill battle, General Li won a great victory. Now the head of state decide to reward him with honor and treasures for his great exploit.

One of these treasures is a necklace made up of 26 different kinds of gemstones, and the length of the necklace is n. (That is to say: n gemstones are stringed together to constitute this necklace, and each of these gemstones belongs to only one of the 26 kinds.)

In accordance with the classical view, a necklace is valuable if and only if it is a palindrome - the necklace looks the same in either direction. However, the necklace we mentioned above may not a palindrome at the beginning. So the head of state decide to cut the necklace into two part, and then give both of them to General Li.

All gemstones of the same kind has the same value (may be positive or negative because of their quality - some kinds are beautiful while some others may looks just like normal stones). A necklace that is palindrom has value equal to the sum of its gemstones' value. while a necklace that is not palindrom has value zero.

Now the problem is: how to cut the given necklace so that the sum of the two necklaces's value is greatest. Output this value.
 

Input

The first line of input is a single integer T (1 ≤ T ≤ 10) - the number of test cases. The description of these test cases follows.

For each test case, the first line is 26 integers: v 1, v 2, ..., v 26 (-100 ≤ v i ≤ 100, 1 ≤ i ≤ 26), represent the value of gemstones of each kind.

The second line of each test case is a string made up of charactor 'a' to 'z'. representing the necklace. Different charactor representing different kinds of gemstones, and the value of 'a' is v 1, the value of 'b' is v 2, ..., and so on. The length of the string is no more than 500000.

 

Output

Output a single Integer: the maximum value General Li can get from the necklace.

 

Sample Input

2
1 1 1 1 1 1 1 1 1 1 1 1 1 1 1 1 1 1 1 1 1 1 1 1 1 1
aba
1 1 1 1 1 1 1 1 1 1 1 1 1 1 1 1 1 1 1 1 1 1 1 1 1 1
acacac

 

Sample Output

1
6

 

题意:

给了一个串由小写字母组成,‘a’到‘z’对应26种颜色的钻石,每种颜色的钻石对应有一个价值,将这个串分成两段,求这两个串的最大价值。规定了若这个串是回文串,则这个串的价值是每个钻石价值相加,若不是钻石,则这个串价值为零。

 

思路:

Manacher变形题,详见代码解析

 

代码:

#include<iostream>
#include<cstdio>
#include<cstdlib>
#include<cstring>
#include<string>
#include<queue>
#include<algorithm>
#include<map>
#include<iomanip>
#define INF 99999999
using namespace std;
const int MAX=500000+10;
char s[MAX*2];
int Mp[MAX*2],sum[MAX],val[27];//sum为前i个字符价值和
int pre[MAX],pos[MAX];//pre标记前i个字符为回文串,pos标记后i个字符为回文串
int main(){
	int n;
	cin>>n;
	while(n--)
    {
		for(int i=0;i<26;++i)
		    scanf("%d",&val[i]);
		scanf("%s",s);
		int len=strlen(s),id=0,ans=-INF,temp=0;
		for(int i=1;i<=len;++i)
		    sum[i]=sum[i-1]+val[s[i-1]-'a'];
		for(int i=len;i>=0;--i)
		{
			s[i+i+2]=s[i];
			s[i+i+1]='#';
		}
		s[0]='*';
		for(int i=2;i<len+len+1;++i)
		{
			if(Mp[id]+id>i)Mp[i]=min(Mp[2*id-i],Mp[id]+id-i);
			else Mp[i]=1;
			while(s[i-Mp[i]] == s[i+Mp[i]])++Mp[i];
			if(id+Mp[id]<i+Mp[i])id=i;
			if(i-Mp[i]==0)pre[Mp[i]-1]=n+1;//表示前缀(前Mp[i]-1个字符)是回文串
			if(i+Mp[i]==len+len+2)pos[Mp[i]-1]=n+1;//表示后缀(后Mp[i]-1个字符)是回文串
		}
		for(int i=1;i<len;++i)
		{
			if(pre[i] == n+1)
			    temp+=sum[i];
			if(pos[len-i]==n+1)
			    temp+=sum[len]-sum[i];
			if(temp>ans)
                ans=temp;
			temp=0;
		}
		cout<<ans<<endl;
	}
	return 0;
}

 

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值