HDU 2824 The Euler function(欧拉函数)

Problem Description

The Euler function phi is an important kind of function in number theory, (n) represents the amount of the numbers which are smaller than n and coprime to n, and this function has a lot of beautiful characteristics. Here comes a very easy question: suppose you are given a, b, try to calculate (a)+ (a+1)+....+ (b)

 

Input

There are several test cases. Each line has two integers a, b (2<a<b<3000000).

 

Output

Output the result of (a)+ (a+1)+....+ (b)

 

Sample Input

3 100

 

Sample Output

3042

 

题意:

给两个数a和b,求这两个数之间的数的欧拉函数值之和

 

思路:

利用欧拉函数和它本身不同质因数的关系,用筛法计算出某个范围内所有数的欧拉函数值。

(p是数N的质因数

 

代码:

#include<cstdio>
#include<iostream>
#include<algorithm>
using namespace std;
#define LL long long
#define max 3000010
LL la[max];
void eular()
{
	int i,j;
	la[1]=0;
	for(i=2;i<max;++i)
		la[i]=i;
	for(i=2;i<max;++i)
	{
		if(la[i]==i)
		{
			for(j=i;j<max;j=j+i)
				la[j]=la[j]/i*(i-1);
		}
	}
	for(i=2;i<max;++i)
		la[i]=la[i]+la[i-1];
}

int main()
{
	eular();
    int a,b;
    LL sum=0;
    while(~scanf("%d%d",&a,&b))
    {
	    int i,j;
		sum=la[b]-la[a-1];
		printf("%lld\n",sum);
	}
}

 

评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值