HDU 2588 GCD(欧拉函数)

Problem Description

The greatest common divisor GCD(a,b) of two positive integers a and b,sometimes written (a,b),is the largest divisor common to a and b,For example,(1,2)=1,(12,18)=6.
(a,b) can be easily found by the Euclidean algorithm. Now Carp is considering a little more difficult problem:
Given integers N and M, how many integer X satisfies 1<=X<=N and (X,N)>=M.

 

Input

The first line of input is an integer T(T<=100) representing the number of test cases. The following T lines each contains two numbers N and M (2<=N<=1000000000, 1<=M<=N), representing a test case.

 

Output

For each test case,output the answer on a single line.

 

Sample Input

3
1 1
10 2
10000 72

 

Sample Output

1
6
260

 

题意:

已知n和m,求1=< i <= n  且 gcd(i,n)>= m 的 i 的个数

 

思路:

对于所有小于等于n的最大公约数值一定是n的因子,所以,我们枚举每个符合条件的因子并将其欧拉函数累加即得到。

 

代码:

#include<iostream>
#include<cstdio>
using namespace std;
typedef long long LL;
const int N=1010;
LL n,m;
LL Euler(LL n)
{
    LL ans=1;
	for(int i=2;i*i<=n;i++)
        {
		if(n%i==0)
		{
			n/=i;
			ans*=(i-1);
			while(n%i==0)
			{
				n/=i;
				ans*=i;
			}
		}
	}
	if(n>1)
	  ans*=(n-1);
	return ans ;
}
int main()
{
	int t;
	scanf("%d",&t);
	while(t--)
        {
		scanf("%lld%lld",&n,&m);
		LL ans=0;
		for(int i=1;i*i<=n;i++)
		{
			if(n%i!=0)
			   continue;
			if(i>=m&&i*i!=n)
				ans+=Euler(n/i);
			if(n/i>=m)
				ans+=Euler(i);
		}
		printf("%lld\n",ans);
	}
	return 0;
}

 

评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值