HDU 1078 FatMouse and Cheese(dp&记忆化搜索)

本文介绍了一个关于FatMouse在网格中寻找最多奶酪的问题,FatMouse从(0,0)开始,每次最多移动k步且必须前往奶酪数量更多的位置。给定n行n列的奶酪分布和移动步数k,求FatMouse能收集到的最多奶酪数。题目提供了样例输入和输出,以及相应的解题思路和代码实现。" 80735290,7782233,D3.js V5在Vue中的交互实现,"['d3-v5-vue', 'd3', 'vue', '交互式图表']
摘要由CSDN通过智能技术生成

Problem Description

FatMouse has stored some cheese in a city. The city can be considered as a square grid of dimension n: each grid location is labelled (p,q) where 0 <= p < n and 0 <= q < n. At each grid location Fatmouse has hid between 0 and 100 blocks of cheese in a hole. Now he’s going to enjoy his favorite food.

FatMouse begins by standing at location (0,0). He eats up the cheese where he stands and then runs either horizontally or vertically to another location. The problem is that there is a super Cat named Top Killer sitting near his hole, so each time he can run at most k locations to get into the hole before being caught by Top Killer. What is worse – after eating up the cheese at one location, FatMouse gets fatter. So in order to gain enough energy for his next run, he has to run to a location which have more blocks of cheese than those that were at the current hole.

Given n, k, and the number of blocks of cheese at each grid location, compute the maximum amount of cheese FatMouse can eat before being unable to move.

 

 Input

There are several test cases. Each test case consists of

a line containing two integers between 1 and 100: n and k
n lines, each with n numbers: the first line contains the number of blocks of cheese at locations (0,0) (0,1) … (0,n-1); the next line contains the number of blocks of cheese at locations (1,0), (1,1), … (1,n-1), and so on.
The input ends with a pair of -1’s.

 

Output

For each test case output in a line the single integer giving the number of blocks of cheese collected.

 

 Sample Input

3 1

1 2 5

10 11 6

12 12 7

-1 -1

 

Sample Output

37

 

 题意

给出n和k,代表n行n列,每次最多走k步,小老鼠从(0,0)点出发,每次只能往数值比当前位置大的地方走,每次走到一个位置加上那个位置的数值,问能得到的最大数值是多少?

 

代码:

#include<algorithm>
#include<iostream>
#include<cstring>
using namespace std;
int ob[10050][105];
int dp[10050][105];
int dx[4]={0,1,0,-1},
    dy[4]={1,0,-1,0};
int x,y,ans,temp,k;
int search(int q,int w);
int main()
{
    while(cin>>x>>k)
    {
        memset(ob,0,sizeof(ob));
        memset(dp,0,sizeof(dp));
        if(x==-1||y==-1) break;
        y=x;
        ans=0;
        for(int i=1;i<=y;i++)
            for(int t=1;t<=x;t++) cin>>ob[i][t];
            cout<<search(1,1)<<endl;
    }
}
int search(int q,int w)
{
    int nx,ny,t=0;
    if(dp[q][w]>0) return dp[q][w];
    for(int j=1;j<=k;j++)
    for(int i=0;i<4;i++)
    {
        nx=q+dx[i]*j;
        ny=w+dy[i]*j;
        if((nx>=1)&&(nx<=x)&&(ny>=1)&&(ny<=y)&&(ob[q][w]<ob[nx][ny]))
            t=max(t,search(nx,ny));
    }
    return dp[q][w]=t+ob[q][w];
}

 

 

评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值