PAT (Basic Level) Practise (中文) 1054. 求平均值 (20)

1054. 求平均值 (20)

时间限制
400 ms
内存限制
65536 kB
代码长度限制
8000 B
判题程序
Standard
作者
CHEN, Yue

本题的基本要求非常简单:给定N个实数,计算它们的平均值。但复杂的是有些输入数据可能是非法的。一个“合法”的输入是[-1000,1000]区间内的实数,并且最多精确到小数点后2位。当你计算平均值的时候,不能把那些非法的数据算在内。

输入格式:

输入第一行给出正整数N(<=100)。随后一行给出N个实数,数字间以一个空格分隔。

输出格式:

对每个非法输入,在一行中输出“ERROR: X is not a legal number”,其中X是输入。最后在一行中输出结果:“The average of K numbers is Y”,其中K是合法输入的个数,Y是它们的平均值,精确到小数点后2位。如果平均值无法计算,则用“Undefined”替换Y。如果K为1,则输出“The average of 1 number is Y”。

输入样例1:
7
5 -3.2 aaa 9999 2.3.4 7.123 2.35
输出样例1:
ERROR: aaa is not a legal number
ERROR: 9999 is not a legal number
ERROR: 2.3.4 is not a legal number
ERROR: 7.123 is not a legal number
The average of 3 numbers is 1.38
输入样例2:
2
aaa -9999
输出样例2:
ERROR: aaa is not a legal number
ERROR: -9999 is not a legal number
The average of 0 numbers is Undefined

/*

 *  部分正确 15分

 * 思路,用捕获异常来处理输入问题
 * 先用字符串获取录入数据,然后判断是否有.,有.的可能是浮点数,没有的可能是整数
 * 然后如果能成功转成整数,而且在规定范围内的,把数据录入double数组,然后计数器+1
 * 然后如果能成功转成浮点数,而且小数位<=2,而且在规定范围内的,把数据录入double数组,然后计数器+1
 * 如果报错就输出ERROR: X is not a legal number
 * 如果计数器为0说明没有符合的数据,那么输出"The average of 0 numbers is Undefined"避免除0异常
 * 计数器>0,那么把存放合法数据的数组每一项累加然后除以计数器
 */
import java.util.Scanner;
public class num1054 {
    public static void main(String[] args) {
        Scanner input = new Scanner(System.in);
        int n = input.nextInt();
        String[] arr = new String[n];
        double[] result = new double[n];
        int count = 0;
        for (int i = 0; i < arr.length; i++) {
            arr[i] = input.next();

            try {
                if (!arr[i].contains(".")) {
                    if (Integer.parseInt(arr[i])>=-1000&&Integer.parseInt(arr[i])<=1000) {
                        result[i] = Integer.parseInt(arr[i]);
                        count++;
                    }else {
                        throw new RuntimeException();
                    }
                    
                }else {
                    if (arr[i].split("\\.")[1].length() <= 2) {
                        //System.out.println(arr[i]+"切下来的小数位长度="+arr[i].split("\\.")[1].length());
                        if (Double.parseDouble(arr[i])>=-1000&&Double.parseDouble(arr[i])<=1000) {
                            result[i] = Double.parseDouble(arr[i]);
                            count++;
                        }else {
                            throw new RuntimeException();
                        }
                        
                    }else {
                        throw new RuntimeException();//小数位长度大于2的浮点数
                    }
                    
                }
                
                
                
        
            } catch (Exception e) {
                System.out.println("ERROR: " + arr[i]+ " is not a legal number");
            }
        }
        
        double sum = 0;
        for (int i = 0; i < result.length; i++) {
            sum += result[i];
        }
        if (count > 0) {
            System.out.printf("The average of %d numbers is %.2f\n", count, sum
                    / count);
        } else {
            System.out.println("The average of 0 numbers is Undefined");
        }
//        for (int i = 0; i < result.length; i++) {
//            System.out.println(result[i]);
//        }

    }
}


  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值