Harmonic Number (II)

#原题:
I was trying to solve problem ‘1234 - Harmonic Number’, I wrote the following code

long long H( int n ) {
long long res = 0;
for( int i = 1; i <= n; i++ )
res = res + n / i;
return res;
}

Yes, my error was that I was using the integer divisions only. However, you are given n, you have to find H(n) as in my code.

Input
Input starts with an integer T (≤ 1000), denoting the number of test cases.

Each case starts with a line containing an integer n (1 ≤ n < 231).

Output
For each case, print the case number and H(n) calculated by the code.

Sample Input
11
1
2
3
4
5
6
7
8
9
10
2147483647
Sample Output
Case 1: 1
Case 2: 3
Case 3: 5
Case 4: 8
Case 5: 10
Case 6: 14
Case 7: 16
Case 8: 20
Case 9: 23
Case 10: 27
Case 11: 46475828386
##题解:
本题求n对1–n的数值取余的总和,由于数值太大用暴力的方法会超时,所以找规律,从n到n/2的范围余值都为1,n/2到n/3的范围取值都为2……例如10,余值为1的数为10,9,8,7,6,余值为2的数为5,4,余值为3的数为3,此时10/3=3,而2^16范围内不会超时,所以以sqrt(n)为界限,代码如下:

#include<stdio.h>
#include<math.h>
int main()
{
	long long n,sum,e,w;
	int x,flag=1;
	scanf("%d",&x);
	while(x--)
	{
		sum=0;
		scanf("%lld",&n);
		int q=sqrt(n),i;
		for(i=1;i<=q;i++)
		{
			sum+=n/i;//1到sqrt(n)的范围用遍历的方法
			e=n/i;
			w=n/(i+1);
			if(e>w)//可以分别算出余值为1,2,3,,,sqrt(n)的相关数据
			sum+=(e-w)*i;
		}
		if(n/q==q)//如果条件成立,则q加了两次,需要减去1次
		sum-=q;
		printf("Case %d: %lld\n",flag,sum);
		flag++;
	}
	return 0;
}
  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值