Harmonic Number (II) (规律题)

Harmonic Number (II)

LightOJ - 1245

I was trying to solve problem ‘1234 - Harmonic Number’, I wrote the following code

long long H( int n ) {
    long long res = 0;
    for( int i = 1; i <= n; i++ )
        res = res + n / i;
    return res;
}

Yes, my error was that I was using the integer divisions only. However, you are given n, you have to find H(n) as in my code.

Input

Input starts with an integer T (≤ 1000), denoting the number of test cases.
Each case starts with a line containing an integer n (1 ≤ n < 231).

Output

For each case, print the case number and H(n) calculated by the code.

Sample Input

11
1
2
3
4
5
6
7
8
9
10
2147483647

Sample Output

Case 1: 1
Case 2: 3
Case 3: 5
Case 4: 8
Case 5: 10
Case 6: 14
Case 7: 16
Case 8: 20
Case 9: 23
Case 10: 27
Case 11: 46475828386

题意:

求(int)n/i(1<=i<=n)的累加

思路:

i从1开始,第i个数的值为n/i,值为n/i的最小的数为i,最大的数为n/(n/i),则值为n/i的数有(n/(n/i)-i+1)个,和为(n/(n/i)-i+1) *(n/i)
例如:n=10,则n/1=10,n/10=1,即1~1的值为10
n/2=5,n/5=2,即2~2的值为5
n/3=3,n/3=3,即3~3的值为3
n/4=2,n/2=5,即4~5的值为2
n/6=1,n/1=10,即6~10的值为1

ac代码:
#include <math.h>
#include <algorithm>
#include <cstdio>
#include <cstdlib>
#include <cstring>
#include <iostream>
#include <map>
#include <queue>
#include <stack>
using namespace std;

const int N = 1e7 + 5;
const int M = 1e6 + 5;
const int mod = 1e9 + 7;
const int INF = 0x3f3f3f3f;

typedef long long ll;
typedef pair<int, int> PII;

int main() {
    int t;
    scanf("%d", &t);

    ll n, ans;
    for (int tt = 1; tt <= t; tt++) {
        scanf("%lld", &n);

        ans = 0;
        ll i = 1;
        while(n / i != 1){
            ans += (n / (n / i) - i + 1) * (n / i);
            i += (n / (n / i) - i + 1);
        }
        ans += n / 2;
        if(n % 2 != 0){
            ans++;
        }
        printf("Case %d: %lld\n", tt, ans);       
    }
    return 0;
}
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值