H. Happy Reversal

H. Happy Reversal

Time Limit: 1000ms
Memory Limit: 65536KB
Elfness is studying in an operation " NOT".
For a binary number A, if we do operation " NOT A", after that, all digits of A will be reversed. (e.g. A= 1001101, after operation " NOT A", A will be   0110010).
Now Elfness has N binary numbers of length K, now he can do operations " NOT" for some of his numbers. 
Let's assume after his operations, the maximum number is M, the minimum number is P. He wants to know what's the maximum M - P he can get. Can you help him?
 

Input

The first line of input is an integer T (T ≤ 60), indicating the number of cases.
For each case, the first line contains 2 integers N (1 ≤ N ≤ 10000) and K (1 ≤ K ≤ 60), the next N lines contains N binary numbers, one number per line, indicating the numbers that Elfness has. The length of each binary number is K.
 

Output

For each case, first output the case number as "Case #x: ", and x is the case number. Then you should output an integer, indicating the maximum result that Elfness can get.

Sample Input

2
5 6
100100
001100
010001
010001
111111
5 7
0001101
0001011
0010011
0111000
1001011

Sample Output

Case #1: 51
Case #2: 103
题目意思是有多个01串,可以选择反转或者不反转,求出最大值与最小值的最大差
看完题目后,直接暴力,提交后毫无悬念的超时了,这个题的关键是怎么找到最大值与最小值,因为
一个串你只能选择一个值,但又不能保证选择一个值得情况下,就是最好的结果,想了好久也没
想明白,看了别人的代码后,才明白,最大值或最小值是由二进制得来的,应该用异或来解决
#include <cstdio>
#include <cstring>
#include <iostream>
#include <algorithm>
using namespace std;

int n,m,h;
char str[100];
long long a[20010];

long long pow(int k){
    return 1LL<<k;
}

long long solve(){
    if(n==1)
        return 0;
    if(a[0]^a[h-1])
        return max(a[h-2]-a[0],a[h-1]-a[1]);
    else
        return a[h-1]-a[0];
}

int main(){
    long long Max,p,q;
    int i,j,k,t,l=1;
    scanf("%d",&t);
    while(t--){
        h=0;
        scanf("%d%d",&n,&m);
        for(k=0;k<n;k++){
            scanf("%s",str);
            p=0;
            q=0;
            for(i=m-1,j=0;i>=0;i--,j++){
                if(str[i]=='0') p+=pow(j);
                else q+=pow(j);
            }
            a[h++]=p;
            a[h++]=q;
        }
        sort(a,a+h);
        printf("Case #%d: %lld\n",l++,solve());
    }
    return 0;
}



  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值