fzu 1150 Farmer Bill's Problem

Problem 1150 Farmer Bill's Problem

Accept: 877    Submit: 1805
Time Limit: 1000 mSec    Memory Limit : 32768 KB

 Problem Description

Peter has n cigarettes. He smokes them one by one keeping all the butts. Out of k > 1 butts he can roll a new cigarette.

How many cigarettes can Peter have?

 Input

Input is a sequence of lines. Each line contains two integer numbers giving the values of n and k.

 Output

For each line of input, output one integer number on a separate line giving the maximum number of cigarettes that Peter can have.

 Sample Input

4 3
10 3
100 5

 Sample Output

5
14
124

题意:
跟空瓶子换汽水一样,k个烟头换1个香烟
#include <queue>
#include <cstdio>
#include <cstring>
#include <iostream>
#include <algorithm>
#define INF 0x3f3f3f
using namespace std;

int main(){
    int n,k,t,s;
    while(~scanf("%d%d",&n,&k)){
        s=n;
        while(n>=k){
            t=n/k;
            s+=n/k;
            n=n%k;
            n+=t;
        }
        printf("%d\n",s);
    }
    return 0;
}


  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值