nyoj 545 Metric Matrice

Metric Matrice

时间限制: 1000 ms  |  内存限制: 65535 KB
难度: 1
描述

Given as input a square distance matrix, where a[i][j] is the distance between point i and point j, determine if the distance matrix is "a  metric" or not.

A distance matrix a[i][j] is a metric if and only if

    1.  a[i][i] = 0

    2, a[i][j]> 0  if i != j

    3.  a[i][j] = a[j][i]

    4.  a[i][j] + a[j][k] >= a[i][k]  i ¹ j ¹ k

输入
The first line of input gives a single integer, 1 ≤ N ≤ 5, the number of test cases. Then follow, for each test case,
* Line 1: One integer, N, the rows and number of columns, 2 <= N <= 30
* Line 2..N+1: N lines, each with N space-separated integers 
(-32000 <=each integer <= 32000).
输出
Output for each test case , a single line with a single digit, which is the lowest digit of the possible facts on this list:
* 0: The matrix is a metric
* 1: The matrix is not a metric, it violates rule 1 above
* 2: The matrix is not a metric, it violates rule 2 above
* 3: The matrix is not a metric, it violates rule 3 above
* 4: The matrix is not a metric, it violates rule 4 above
样例输入
240 1 2 31 0 1 22 1 0 13 2 1 020 32 0
样例输出

03

题目不难,关键是理解意思,当多个条件不满足时,取序号最小的条件

#include <cstdio>
#include <cstring>
#include <iostream>
using namespace std;

int a[50][50];

int main(){
    int i,j,k,t,n,f;
    scanf("%d",&t);
    while(t--){
        f=0;
        scanf("%d",&n);
        for(i=1;i<=n;i++)
            for(j=1;j<=n;j++)
            scanf("%d",&a[i][j]);

        for(i=1;i<=n;i++)
            if(a[i][i]!=0&&!f) f=1;

        for(i=1;i<=n;i++)
        for(j=1;j<=n;j++){
            if(i!=j&&!f){
                if(a[i][j]<=0) f=2;
            }
        }

        for(i=1;i<=n;i++)
        for(j=1;j<=n;j++){
            if(i!=j&&!f){
                if(a[i][j]!=a[j][i]) f=3;
            }
        }

        for(i=1;i<=n;i++)
            for(j=1;j<=n;j++)
        for(k=1;k<=n;k++){
            if((i!=j)&&(j!=k)&&(i!=k)&&!f){
                if(a[i][j]+a[j][k]<a[i][k]){
                    f=4;
                }
            }
        }
        if(f)
            printf("%d\n",f);
        else
            printf("0\n");
    }
    return 0;
}


  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值