HDU1061——Rightmost Digit

Problem Description

Given a positive integer N, you should output the most right digit of N^N.

Input

The input contains several test cases. The first line of the input is a single integer T which is the number of test cases. T test cases follow.

Each test case contains a single positive integer N(1<=N<=1,000,000,000).

Output

For each test case, you should output the rightmost digit of N^N.

Sample Input

2

3

4

Sample Output

7

6

此题明显不能暴力求解N^N,显然数太大并且会超时。通过找规律可以知道数与数相乘其个位数至于两个乘数有关,所以只需提取每个乘数的个位数字即可。但提交过后发现报错TLE.再加思考很容易发现一个数连乘其个位数是几个数字的循环,所以只要找出此题的循环节即可。

AC代码:

#include<iostream>
#include<algorithm>
#include<memory.h>
using namespace std;
typedef long long ll;
int a[10],b[10];

int main()
{
	int T, i;
	ll n;
	cin >> T;
	while (T--)
	{
		for (int i = 0; i < 10; i++)
			a[i] = 0;
		int cnt = 0;
		cin >> n;
		int temp = n % 10, res=1;
		for (i = 0; i < 10; i++)
		{	
			res = res*temp%10;
			a[res] += 1;
			b[i] = res;
			if (a[res] == 2)
				break;
			cnt++;
		}
		if (n % cnt == 0)
			cout << b[cnt - 1] << endl;
		else
			cout << b[n%cnt - 1] << endl;
	}
	return 0;
}

 

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值