HDU——1061 Rightmost Digit

2 篇文章 0 订阅
1 篇文章 0 订阅
Given a positive integer N, you should output the most right digit of N^N. 
Input
    The input contains several test cases. The first line of the input is a single integer T which is the number of test cases. T test cases follow. 
    Each test case contains a single positive integer N(1<=N<=1,000,000,000). 
Output
    For each test case, you should output the rightmost digit of N^N. 
Sample Input
    2
    3
    4
Sample Output
    7
    6
#include <iostream>

using namespace std;

long long fun(long long a)
{
    long long sum=1;
    long long b;
    int s=1;
    b=a%20;
    if(b==0)
    {
        b=10;
    }
    for(int i=0;i<b;i++)
    {
        sum=s*b;
        s=sum%10;
    }

    return s;
}

int main()
{
    int n;
    long x;
    cin>>n;
    while(n)
    {
        n--;
        cin>>x;
        cout<<fun(x)<<endl;
    }

    return 0;
}
  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值