NYOJ-a letter and a number

a letter and a number
时间限制: 3000 ms  |  内存限制: 65535 KB
难度: 1
描述
we define f(A) = 1, f(a) = -1, f(B) = 2, f(b) = -2, ... f(Z) = 26, f(z) = -26;
Give you a letter x and a number y , you should output the result of y+f(x).
输入
On the first line, contains a number T(0<T<=10000).then T lines follow, each line is a case.each case contains a letter x and a number y(0<=y<1000).
输出
for each case, you should the result of y+f(x) on a line
样例输入
6
R 1
P 2
G 3
r 1
p 2
g 3
样例输出
19
18
10
-17
-14
-4
代码:
  1. #include<stdio.h>  
  2. int main() 
  3.     int t,y; 
  4.     char ch; 
  5.     scanf("%d",&t); 
  6.     while(t--) 
  7.     { 
  8.         getchar();  //注意字符输入时可能出现的问题,否则ch可能会接收'\n'; 
  9.         scanf("%c%d",&ch,&y); 
  10.         if(ch>='a'&&ch<='z'
  11.         printf("%d\n",y-(ch-'a'+1)); 
  12.         else 
  13.         printf("%d\n",y+(ch-'A'+1)); 
  14.     } 
  15.     return 0
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值