POJ-Dungeon Master(bfs)

42 篇文章 1 订阅
4 篇文章 0 订阅

除了自己,任何人都无法给你力量。
没有口水与汗水,就没有成功的泪水。

POJ-Dungeon Master

题目描述

You are trapped in a 3D dungeon and need to find the quickest way out! The dungeon is composed of unit cubes which may or may not be filled with rock. It takes one minute to move one unit north, south, east, west, up or down. You cannot move diagonally and the maze is surrounded by solid rock on all sides.
Is an escape possible? If yes, how long will it take?

输入

The input consists of a number of dungeons. Each dungeon description starts with a line containing three integers L, R and C (all limited to 30 in size).
L is the number of levels making up the dungeon.
R and C are the number of rows and columns making up the plan of each level.
Then there will follow L blocks of R lines each containing C characters. Each character describes one cell of the dungeon. A cell full of rock is indicated by a ‘#’ and empty cells are represented by a ‘.’. Your starting position is indicated by ‘S’ and the exit by the letter ‘E’. There’s a single blank line after each level. Input is terminated by three zeroes for L, R and C.

输出

Each maze generates one line of output. If it is possible to reach the exit, print a line of the form
Escaped in x minute(s).
where x is replaced by the shortest time it takes to escape.
If it is not possible to escape, print the line
Trapped!

Sample Input

3 4 5
S....
.###.
.##..
###.#

#####
#####
##.##
##...

#####
#####
#.###
####E

1 3 3
S##
#E#
###

0 0 0

Sample Output

Escaped in 11 minute(s).
Trapped!

题目大意
这是一个三维的迷宫,给了你每一层的切片,’#‘是不可走的,‘S’,’.’,'E’均是可走的
需要你找出来从S走到E的最短路径

思路分析
这题其实就是一个简单的bfs的扩展,只需要判断起点终点位置,以及朝六个方向的哪个方向走,可不可以走。就可以了

特别注意:不要忘记judge函数的清空,以及queue的清空

AC时间到

也没有什么好注意的地方,直接写bfs就可以了

END

#include<algorithm>
#include<iostream>
#include<string.h>
#include<utility>
#include<stdio.h>
#include<vector>
#include<string>
#include<math.h>
#include<cmath>
#include<queue>
#include<stack>
#include<deque>
#include<map>
#pragma warning(disable:4244)
#define PI 3.1415926536
#pragma GCC optimize(2)
using namespace std;
typedef long long ll;
typedef unsigned long long ull;
const ll ll_inf = 9223372036854775807;
const int int_inf = 2147483647;
const short short_inf = 32767;
const char char_inf = 127;
ll GCD(ll a, ll b) { return a ? GCD(b, a % b) : a; }
inline ll read() {
	ll c = getchar(), Nig = 1, x = 0;
	while (!isdigit(c) && c != '-')c = getchar();
	if (c == '-')Nig = -1, c = getchar();
	while (isdigit(c))x = ((x << 1) + (x << 3)) + (c ^ '0'), c = getchar();
	return Nig * x;
}
inline void out(ll a)
{
	if (a < 0)putchar('-'), a = -a;
	if (a >= 10)out(a / 10);
	putchar(a % 10 + '0');
}
ll qpow(ll x, ll n, ll mod) {
	ll res = 1;
	while (n > 0) {
		if (n & 1)res = (res * x) % mod;
		x = (x * x) % mod; n >>= 1;
	}
	return res;
}
#define read read()
struct node {
	int x, y, z, step;
};
node STA, END;
char save[50][50][50];
bool judge[50][50][50];
int z, x, y;
queue<node>q;
node temp;
bool Judge(node a, node b)
{
	if (a.x == b.x && a.y == b.y && a.z == b.z)return 1;
	return 0;
}
void bfs()
{
	while (1)
	{
		if (q.empty())
		{
			puts("Trapped!");
			return;
		}
		temp = q.front();
		q.pop();
		if (Judge(temp, END))
		{
			printf("Escaped in %d minute(s).\n", temp.step);
			return;
		}
		if (!judge[temp.x][temp.y][temp.z + 1] && save[temp.z + 1][temp.x][temp.y] == '.') {
			q.push(node{ temp.x,temp.y,temp.z + 1,temp.step + 1 });
			judge[temp.x][temp.y][temp.z + 1] = true;
		}
		if (!judge[temp.x][temp.y][temp.z - 1] && save[temp.z - 1][temp.x][temp.y] == '.') {
			q.push(node{ temp.x,temp.y,temp.z - 1 ,temp.step + 1 });
			judge[temp.x][temp.y][temp.z - 1] = true;
		}
		if (!judge[temp.x + 1][temp.y][temp.z] && save[temp.z][temp.x + 1][temp.y] == '.') {
			q.push(node{ temp.x + 1,temp.y,temp.z,temp.step + 1 });
			judge[temp.x + 1][temp.y][temp.z] = true;
		}
		if (!judge[temp.x - 1][temp.y][temp.z] && save[temp.z][temp.x - 1][temp.y] == '.') {
			q.push(node{ temp.x - 1,temp.y,temp.z,temp.step + 1 });
			judge[temp.x - 1][temp.y][temp.z] = true;
		}
		if (!judge[temp.x][temp.y + 1][temp.z] && save[temp.z][temp.x][temp.y + 1] == '.') {
			q.push(node{ temp.x,temp.y + 1,temp.z,temp.step + 1 });
			judge[temp.x][temp.y + 1][temp.z] = true;
		}
		if (!judge[temp.x][temp.y - 1][temp.z] && save[temp.z][temp.x][temp.y - 1] == '.') {
			q.push(node{ temp.x,temp.y - 1,temp.z,temp.step + 1 });
			judge[temp.x][temp.y - 1][temp.z] = true;
		}
	}
}
int main()
{
	while (scanf("%d%d%d", &z, &x, &y))
	{
		if ((!x) && (!y) && (!z))return 0;
		for (int i = 1; i <= z; i++)
			for (int j = 1; j <= x; j++)
				scanf("%s", save[i][j] + 1);
		for (int i = 1; i <= z; i++)
			for (int j = 1; j <= x; j++)
				for (int k = 1; k <= y; k++)
				{
					if (save[i][j][k] == 'S')
						STA.x = j, STA.y = k, STA.z = i;
					else if (save[i][j][k] == 'E')
					{
						END.x = j, END.y = k, END.z = i;
						save[i][j][k] = '.';
					}
				}
		q.push(node{ STA.x,STA.y,STA.z,0 });
		judge[STA.x][STA.y][STA.z] = true;
		bfs();
		memset(save, 0, sizeof(save));
		memset(judge, 0, sizeof(judge));
		while (!q.empty())q.pop();
	}
}

By-轮月

  • 1
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 打赏
    打赏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包

打赏作者

Round moon

你的鼓励将是我创作的最大动力

¥1 ¥2 ¥4 ¥6 ¥10 ¥20
扫码支付:¥1
获取中
扫码支付

您的余额不足,请更换扫码支付或充值

打赏作者

实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值