POJ 1014 Dividing(入门例题一)

Time Limit: 1000MS              Memory Limit: 10000K
Total Submissions: 77601        Accepted: 20426

Description

Marsha and Bill own a collection of marbles. They want to split the collection among themselves so that both receive an equal share of the marbles. This would be easy if all the marbles had the same value, because then they could just split the collection in half. But unfortunately, some of the marbles are larger, or more beautiful than others. So, Marsha and Bill start by assigning a value, a natural number between one and six, to each marble. Now they want to divide the marbles so that each of them gets the same total value. Unfortunately, they realize that it might be impossible to divide the marbles in this way (even if the total value of all marbles is even). For example, if there are one marble of value 1, one of value 3 and two of value 4, then they cannot be split into sets of equal value. So, they ask you to write a program that checks whether there is a fair partition of the marbles.

Input

Each line in the input file describes one collection of marbles to be divided. The lines contain six non-negative integers n1 , . . . , n6 , where ni is the number of marbles of value i. So, the example from above would be described by the input-line "1 0 1 2 0 0". The maximum total number of marbles will be 20000. 
The last line of the input file will be "0 0 0 0 0 0"; do not process this line.

Output

For each collection, output "Collection #k:", where k is the number of the test case, and then either "Can be divided." or "Can't be divided.". 
Output a blank line after each test case.

Sample Input

1 0 1 2 0 0 
1 0 0 0 1 1 
0 0 0 0 0 0 

Sample Output

Collection #1:
Can't be divided.

Collection #2:
Can be divided.

解题思路

因为是第一道例题,所以只做一些大佬AC代码的笔记,以下是参考博客的讲解:

如果总价值为奇数,那么肯定是不能分的。如果总价值为偶数,也不一定能分,因为一个弹珠是不能被拆分的。

以总价值的1/2为背包容量,进行动态规划求解。还用了二进制优化的方法,可以说这道题目是简单的多重背包吧。

dp[x]=1表示这些弹珠可以凑出价值为x的部分,否则就是不能凑成价值为x的部分。

参考博客

https://blog.csdn.net/u011561033/article/details/39526897

 AC代码

#include<cstdio>
#include<cstring>
#include<algorithm>
using namespace std;
int main()
{
    int n,sum,i,j,k,cs=1;
    int a[11];
    int dp[222222]; //大于6*20000
    while(scanf("%d",&a[1])!=-1)
    {
        sum=a[1];
        for(i=2; i<=6; i++)
        {
            scanf("%d",&a[i]);//i为1,2,3,4,5,6,存储各类弹珠数量
            sum+=a[i]*i;
        }
        if(sum<=0)break; //没有弹珠,即最后一行的情况
        memset(dp,0,sizeof(dp));
        printf("Collection #%d:\n",cs++);
        if(sum%2)printf("Can't be divided.\n");//奇数一定不可分
        else
        {
            dp[0]=1; //初始化0,0肯定是可分出来的
            sum/=2; //背包容量
            for(i=1; i<=6; i++)
            {
                if(a[i]==0)continue;
                for(k=1; k<=a[i]; k*=2)//先处理偶数情况,将偶数分值归到dp中,倒序同样是因为还原成了0-1背包问题,将大物品拆分成了各个小物品
                {
                    for(j=sum; j>=0; j--)
                    {
                        if(dp[j]==0||j+i*k>sum)continue;
                        dp[j+i*k]=1;
                    }
                    a[i]-=k;
                }
                if(a[i]>0)//处理剩余的数的情况,比如10分为1,2,4之后还剩3
                {
                    for(j=sum; j>=0; j--)
                    {
                        if(dp[j]==0||j+i*a[i]>sum)continue;
                        dp[j+i*a[i]]=1;
                    }
                }
            }
            if(dp[sum]==1)
                printf("Can be divided.\n");
            else printf("Can't be divided.\n");
        }
        printf("\n");
    }
    return 0;
}

 

转载于:https://www.cnblogs.com/yun-an/p/10961726.html

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值