poj 3302 Subsequence

Subsequence
Time Limit: 1000MS Memory Limit: 65536K
Total Submissions: 6865 Accepted: 3998

Description

Given a string s of length n, a subsequence of it, is defined as another string s' = su1su2...sum where 1 ≤ u1 < u2 < ... < umn and si is the ith character of s. Your task is to write a program that, given two strings s1 and s2, checks whether either s2 or its reverse is a subsequence of s1 or not.

Input

The first line of input contains an integer T, which is the number of test cases. Each of the next T lines contains two non-empty strings s1 and s2 (with length at most 100) consisted of only alpha-numeric characters and separated from each other by a single space.

Output

For each test case, your program must output "YES", in a single line, if either s2 or its reverse is a subsequence of s1. Otherwise your program should write "NO".

Sample Input

5
arash aah
arash hsr
kick kkc
A a
a12340b b31

Sample Output

YES
YES
NO
NO
YES
#include<iostream>
using namespace std;
int main()
{
int n;
char a[101],b[101];
int i,j;
int lena,lenb;
int mark;
int res1,res2;
cin>>n;
while(n--)
{
cin>>a;
cin>>b;
lena=strlen(a);
lenb=strlen(b);
mark=0;
for(j=0;j<lenb;j++)
{
for(i=mark;i<lena;i++)
{
if(b[j]==a[i])
break;
}
if(i==lena)
{
res1=0;
break;
}
else
mark=i+1;
}
if(j==lenb)
res1=1;
mark=0;
for(j=lenb-1;j>=0;j--)
{
for(i=mark;i<lena;i++)
{
if(b[j]==a[i])
break;
}
if(i==lena)
{
res2=0;
break;
}
else
mark=i+1;
}
if(j==-1)
res2=1;
if(res1==0&&res2==0)
cout<<"NO"<<endl;
else
cout<<"YES"<<endl;
}
return 0;
}
 

转载于:https://www.cnblogs.com/w0w0/archive/2011/11/23/2259805.html

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
信息数据从传统到当代,是一直在变革当中,突如其来的互联网让传统的信息管理看到了革命性的曙光,因为传统信息管理从时效性,还是安全性,还是可操作性等各个方面来讲,遇到了互联网时代才发现能补上自古以来的短板,有效的提升管理的效率和业务水平。传统的管理模式,时间越久管理的内容越多,也需要更多的人来对数据进行整理,并且数据的汇总查询方面效率也是极其的低下,并且数据安全方面永远不会保证安全性能。结合数据内容管理的种种缺点,在互联网时代都可以得到有效的补充。结合先进的互联网技术,开发符合需求的软件,让数据内容管理不管是从录入的及时性,查看的及时性还是汇总分析的及时性,都能让正确率达到最高,管理更加的科学和便捷。本次开发的高校科研信息管理系统实现了操作日志管理、字典管理、反馈管理、公告管理、科研成果管理、科研项目管理、通知管理、学术活动管理、学院部门管理、科研人员管理、管理员管理等功能。系统用到了关系型数据库中王者MySql作为系统的数据库,有效的对数据进行安全的存储,有效的备份,对数据可靠性方面得到了保证。并且程序也具备程序需求的所有功能,使得操作性还是安全性都大大提高,让高校科研信息管理系统更能从理念走到现实,确确实实的让人们提升信息处理效率。
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值