POJ 3302 Subsequence(我的水题之路——子串判断)

Subsequence
Time Limit: 1000MS Memory Limit: 65536K
Total Submissions: 6940 Accepted: 4058

Description

Given a string s of length n, a subsequence of it, is defined as another string s' = su1su2...sum where 1 ≤ u1 < u2 < ... < um ≤ n and si is the ith character of s. Your task is to write a program that, given two strings s1 and s2, checks whether either s2 or its reverse is a subsequence of s1 or not.

Input

The first line of input contains an integer T, which is the number of test cases. Each of the next T lines contains two non-empty strings s1 and s2 (with length at most 100) consisted of only alpha-numeric characters and separated from each other by a single space.

Output

For each test case, your program must output "YES", in a single line, if either s2 or its reverse is a subsequence of s1. Otherwise your program should write "NO".

Sample Input

5
arash aah
arash hsr
kick kkc
A a
a12340b b31

Sample Output

YES
YES
NO
NO
YES

Source


给两个字符串,str1,str2,问是否str2是str1正序或逆序的子串。
如:
1)
arash aah
a r a s h (正序)
a   a    h 是子串
2)
arash hsr
h s a r a(逆序,正序不是)
h s    r   是子串。

直接用一个循环,遍历str1,与str2进行单字符匹配,如果匹配成功就count++,如果count==strlen(str1),则输出YES,遍历正序、逆序各一次,都没有则输出NO。

代码(1AC):
#include <cstdio>
#include <cstdlib>
#include <cstring>

char str1[110];
char str2[110];

int main(void){
    int ii, casenum;
    int count;
    int len1, len2;
    int i, j;
    int flag;

    scanf("%d", &casenum);
    getchar();
    for (ii = 0; ii < casenum; ii++){
        scanf("%s%s", str1, str2);
        len1 = strlen(str1);
        len2 = strlen(str2);
        flag = 0;
        for (i = j = count =  0; !flag && j < len1; j++){
            if (str1[j] == str2[i]){
                count++;
                i++;
            }
            if (count == len2){
                flag = 1;
            }
        }
        for (count = i = 0, j = len1 - 1; !flag && j >= 0; j--){
            if (str1[j] == str2[i]){
                count++;
                i++;
            }
            if (count == len2){
                flag = 1;
            }
        }
        if (flag){
            printf("YES\n");
        }
        else{
            printf("NO\n");
        }
    }
    return 0;
}



  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值