POJ 2195 一人一房 最小费用流 建图 水题

Going Home
Time Limit: 1000MS Memory Limit: 65536K
Total Submissions: 21010 Accepted: 10614

Description

On a grid map there are n little men and n houses. In each unit time, every little man can move one unit step, either horizontally, or vertically, to an adjacent point. For each little man, you need to pay a $1 travel fee for every step he moves, until he enters a house. The task is complicated with the restriction that each house can accommodate only one little man. 

Your task is to compute the minimum amount of money you need to pay in order to send these n little men into those n different houses. The input is a map of the scenario, a '.' means an empty space, an 'H' represents a house on that point, and am 'm' indicates there is a little man on that point. 

You can think of each point on the grid map as a quite large square, so it can hold n little men at the same time; also, it is okay if a little man steps on a grid with a house without entering that house.

Input

There are one or more test cases in the input. Each case starts with a line giving two integers N and M, where N is the number of rows of the map, and M is the number of columns. The rest of the input will be N lines describing the map. You may assume both N and M are between 2 and 100, inclusive. There will be the same number of 'H's and 'm's on the map; and there will be at most 100 houses. Input will terminate with 0 0 for N and M.

Output

For each test case, output one line with the single integer, which is the minimum amount, in dollars, you need to pay.

Sample Input

2 2
.m
H.
5 5
HH..m
.....
.....
.....
mm..H
7 8
...H....
...H....
...H....
mmmHmmmm
...H....
...H....
...H....
0 0

Sample Output

2
10
28

Source

比较好理解,给定一个N*M的地图,地图上有若干个man和house,且man与house的数量一致。man每移动一格需花费$1(即单位费用=单位距离),一间house只能入住一个man。现在要求所有的man都入住house,求最小费用。
#include <iostream>
#include <cstdio>
#include <cstring>
#include <cstdlib>
#include <cmath>
#include <vector>
#include <queue>
#include <map>
#include <algorithm>
#include <set>
using namespace std;
#define MM(a,b) memset(a,b,sizeof(a))
typedef long long ll;
typedef unsigned long long ULL;
const int mod = 1000000007;
const double eps = 1e-10;
const int inf = 0x3f3f3f3f;
const int big=50000;
int max(int a,int b) {return a>b?a:b;};
int min(int a,int b) {return a<b?a:b;};
const int N = 70;
const int M=10000+100;
struct edge{
   int to,cap,cost,rev;
};

vector<edge> G[1005];
int dist[1005],inq[1005],prev[1005],prel[1005];
struct Point{
   int x,y;
};

int n,m,x,y,c,cnth,cntm;
Point house[105],men[105];

void add_edge(int u,int v,int cap,int cost)
{
    G[u].push_back(edge{v,cap,cost,G[v].size()});
    G[v].push_back(edge{u,0,-cost,G[u].size()-1});
}

int mincost(int s,int t,int f)
{
    int ans=0;
    while(f>0)
    {
      memset(dist,inf,sizeof(dist));
      memset(inq,0,sizeof(inq));
      dist[s]=0;
      queue<int> q;
      q.push(s);
      inq[s]=1;
      MM(prev,-1);
      while(!q.empty())
      {
          int u=q.front();
          q.pop();inq[u]=0;
          for(int j=0;j<G[u].size();j++)
            {
                edge &e=G[u][j];
                if(e.cap>0&&dist[e.to]>dist[u]+e.cost)
                   {
                       dist[e.to]=dist[u]+e.cost;
                       prev[e.to]=u;
                       prel[e.to]=j;
                       if(!inq[e.to])
                       {
                           q.push(e.to);
                           inq[e.to]=1;
                       }
                   }
            }
       }
       for(int i=t;i>s;)
       {
           int f=prev[i];
           if(f==-1) return -1;
           int j=prel[i];
           G[f][j].cap-=1;
           G[i][G[f][j].rev].cap+=1;
           ans+=G[f][j].cost;
           i=prev[i];
       }
       f-=1;
    }
    return ans;
}

void build()
{
    for(int i=0;i<=cnth+cntm+1;i++) G[i].clear();
    for(int i=1;i<=cntm;i++)
          add_edge(0,i,1,0);
    for(int i=1;i<=cnth;i++)
          add_edge(cntm+i,cntm+cnth+1,1,0);
    for(int i=1;i<=cntm;i++)
          for(int j=1;j<=cnth;j++)
        {
          int dis=abs(house[j].x-men[i].x)+abs(house[j].y-men[i].y);
          add_edge(i,j+cntm,1,dis);
        }
}

char s[105][105];
int main()
{
    int n,m;
    while(~scanf("%d %d",&n,&m)&&(n||m))
    {
        cnth=cntm=0;
        for(int i=1;i<=n;i++)
           {
               scanf("%s",s[i]);
               for(int j=0;j<m;j++)
                   if(s[i][j]=='H')
                      house[++cnth]=(Point){i,j+1};
                   else if(s[i][j]=='m')
                      men[++cntm]=(Point){i,j+1};
           }
        build();
        printf("%d\n",mincost(0,cnth+cntm+1,cnth));
    }
    return 0;
}

  分析:建图有一点点技术含量,人放左边,门放右边,加一个源点与汇点,然后跑一跑大小为人数(门数)的最小费用流就好,

转载于:https://www.cnblogs.com/smilesundream/p/5499262.html

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
图像识别技术在病虫害检测中的应用是一个快速发展的领域,它结合了计算机视觉和机器学习算法来自动识别和分类植物上的病虫害。以下是这一技术的一些关键步骤和组成部分: 1. **数据收集**:首先需要收集大量的植物图像数据,这些数据包括健康植物的图像以及受不同病虫害影响的植物图像。 2. **图像预处理**:对收集到的图像进行处理,以提高后续分析的准确性。这可能包括调整亮度、对比度、去噪、裁剪、缩放等。 3. **特征提取**:从图像中提取有助于识别病虫害的特征。这些特征可能包括颜色、纹理、形状、边缘等。 4. **模型训练**:使用机器学习算法(如支持向量机、随机森林、卷积神经网络等)来训练模型。训练过程中,算法会学习如何根据提取的特征来识别不同的病虫害。 5. **模型验证和测试**:在独立的测试集上验证模型的性能,以确保其准确性和泛化能力。 6. **部署和应用**:将训练好的模型部署到实际的病虫害检测系统中,可以是移动应用、网页服务或集成到智能农业设备中。 7. **实时监测**:在实际应用中,系统可以实时接收植物图像,并快速给出病虫害的检测结果。 8. **持续学习**:随着时间的推移,系统可以不断学习新的病虫害样本,以提高其识别能力。 9. **用户界面**:为了方便用户使用,通常会有一个用户友好的界面,显示检测结果,并提供进一步的指导或建议。 这项技术的优势在于它可以快速、准确地识别出病虫害,甚至在早期阶段就能发现问题,从而及时采取措施。此外,它还可以减少对化学农药的依赖,支持可持续农业发展。随着技术的不断进步,图像识别在病虫害检测中的应用将越来越广泛。
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值