ACM LIS 最长子序列问题

E - LIS
Time Limit:1000MS     Memory Limit:65536KB     64bit IO Format:%I64d & %I64u
Submit  Status

Description

The world financial crisis is quite a subject. Some people are more relaxed while others are quite anxious. John is one of them. He is very concerned about the evolution of the stock exchange. He follows stock prices every day looking for rising trends. Given a sequence of numbers p1, p2,...,pn representing stock prices, a rising trend is a subsequence pi1 < pi2 < ... < pik, with i1 < i2 < ... < ik. John’s problem is to find very quickly the longest rising trend.

Input

Each data set in the file stands for a particular set of stock prices. A data set starts with the length L (L ≤ 100000) of the sequence of numbers, followed by the numbers (a number fits a long integer). 
White spaces can occur freely in the input. The input data are correct and terminate with an end of file.

Output

The program prints the length of the longest rising trend. 
For each set of data the program prints the result to the standard output from the beginning of a line.

Sample Input

6 
5 2 1 4 5 3 
3  
1 1 1 
4 
4 3 2 1

Sample Output

3 
1 
1

Hint

There are three data sets. In the first case, the length L of the sequence is 6. The sequence is 5, 2, 1, 4, 5, 3. The result for the data set is the length of the longest rising trend: 3.
解题思路:
题目的大意是,给定一组数据,让我们求出这组数据的最大上升的序列包含元素的个数。这就是一个求最大子序列的问题。利用二分查找和DP可以解决。
程序代码:
#include <iostream>
#include <cstdio>
using namespace std;
long a[100005];
const int N=100005;
int maxlen(int n,long *list)    //list为序列数组,n为list长度
{
    int len=1,left,mid,right,i,dp[N]={0};
    dp[1]=list[1];
    for(i=2;i<=n;i++)
    {
        left=0,right=len;
        while(left<=right)    //二分查找
        {
            mid=(left+right)/2;
            list[i]>dp[mid] ? left=mid+1 : right=mid-1 ;
        }
        dp[left]=list[i];    //更新dp
        if(left>len)
            len++;    //序列长度+1
    }
    return len;
}
int main()
{
	int n;
    while(~scanf("%d",&n))
    {
        for(int i=1; i<=n; i++)
            scanf("%lld",&a[i]);
        printf("%d\n",maxlen(n,a));
    }
	return 0;
}

  

转载于:https://www.cnblogs.com/xinxiangqing/p/4726712.html

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值