POJ 2376 Cleaning Shifts 贪心

Cleaning Shifts

题目连接:

http://poj.org/problem?id=2376

Description

Farmer John is assigning some of his N (1 <= N <= 25,000) cows to do some cleaning chores around the barn. He always wants to have one cow working on cleaning things up and has divided the day into T shifts (1 <= T <= 1,000,000), the first being shift 1 and the last being shift T.

Each cow is only available at some interval of times during the day for work on cleaning. Any cow that is selected for cleaning duty will work for the entirety of her interval.

Your job is to help Farmer John assign some cows to shifts so that (i) every shift has at least one cow assigned to it, and (ii) as few cows as possible are involved in cleaning. If it is not possible to assign a cow to each shift, print -1.

Input

  • Line 1: Two space-separated integers: N and T

  • Lines 2..N+1: Each line contains the start and end times of the interval during which a cow can work. A cow starts work at the start time and finishes after the end time.

Output

  • Line 1: The minimum number of cows Farmer John needs to hire or -1 if it is not possible to assign a cow to each shift.

Sample Input

3 10

1 7

3 6

6 10

Sample Output

2

Hint

题意

给你n个区间,要求你选出最少的区间,使得能够覆盖[1,t]

题解:

dp很简单,dp[i] = min(dp[j])+1,其中需满足a[j].r+1>=a[i].l

贪心也很简单,每次我们扫的时候,直接扫到能够转移到的最右边就好了(其实也是DP思想..

期末考试前写道水题攒攒RP T T

代码

#include<algorithm>
#include<iostream>
#include<stdio.h>
using namespace std;

struct node
{
    int x,y;
};
bool cmp(node a,node b)
{
    if(a.x==b.x)return a.y>b.y;
    return a.x<b.x;
}
node p[25005];

int main()
{
    int n,t;
    scanf("%d%d",&n,&t);
    for(int i=1;i<=n;i++)
        scanf("%d%d",&p[i].x,&p[i].y);
    sort(p+1,p+1+n,cmp);
    int l = 0;
    int ans = 0;
    int i = 1;
    while(i<=n)
    {
        if(p[i].x>l+1)return puts("-1");
        int tmp = l;
        while(i<=n&&p[i].x<=l+1)
        {
            tmp = max(tmp,p[i].y);
            i++;
        }
        l = tmp;ans++;
        if(l>=t)return printf("%d\n",ans);
    }
    return puts("-1");
}

转载于:https://www.cnblogs.com/qscqesze/p/5052796.html

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值