HDU 2289.Cup-二分

Cup

Time Limit: 3000/1000 MS (Java/Others)    Memory Limit: 32768/32768 K (Java/Others)
Total Submission(s): 8946    Accepted Submission(s): 2747


Problem Description
The WHU ACM Team has a big cup, with which every member drinks water. Now, we know the volume of the water in the cup, can you tell us it height?

The radius of the cup's top and bottom circle is known, the cup's height is also known.
 

 

Input
The input consists of several test cases. The first line of input contains an integer T, indicating the num of test cases.
Each test case is on a single line, and it consists of four floating point numbers: r, R, H, V, representing the bottom radius, the top radius, the height and the volume of the hot water.

Technical Specification

1. T ≤ 20.
2. 1 ≤ r, R, H ≤ 100; 0 ≤ V ≤ 1000,000,000.
3. r ≤ R.
4. r, R, H, V are separated by ONE whitespace.
5. There is NO empty line between two neighboring cases.

 

 

Output
For each test case, output the height of hot water on a single line. Please round it to six fractional digits.
 

 

Sample Input
1
100 100 100 3141562
 

 

Sample Output
99.999024
 
 

题意就是已知一个杯子的下底和上底,高度,还知道水的体积,要求水在杯子里的高度。圆台的体积公式V=1/3π(R*R+r*r+R*r),如果r==R,那就是圆柱,圆柱的体积就是圆台的体积的特殊情况嘛。

一个坑就是水在杯子里的上底要相似三角形算出来,哇,垃圾。。。还有一个就是π的精度要准确一些acos(-1.0)。

二分二分!!!

 

代码:

#include<bits/stdc++.h>
using namespace std;
const double pi=acos(-1.0);               //精度很重要
const double eps=1e-9;                    //精度很重要
int n;
double r,R,u,H,V;
double l,rr,mid;

double gg(double h){
    u=h/H*(R-r)+r;                        //相似三角形算出来上面的半径
    return pi/3*h*(r*r+u*u+r*u);          //体积公式
}
int main(){
    while(~scanf("%d",&n)){
        while(n--){
            cin>>r>>R>>H>>V;
                l=0;rr=H;
                while(rr-l>=eps){         //二分
                    mid=(l+rr)/2;
                    if(gg(mid)<=V)
                        l=mid;
                    else
                        rr=mid;
                }
                printf("%.6lf\n",mid);
        }
    }
    return 0;
}

 

 

 

 

 

 

转载于:https://www.cnblogs.com/ZERO-/p/7134438.html

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值