HDU-2114 Calculate S(n)

Description

Calculate S(n).

S(n)=13+23 +33 +......+n3 .

 

Input

Each line will contain one integer N(1 < n < 1000000000). Process to end of file.

 

Output

For each case, output the last four dights of S(N) in one line.

 

Sample Input

1

2

 

Sample Output

0001

0009


生搬硬套公式。

#include <iostream>
#include <cstdio>
using namespace std;

int main(void)
{
    long long t;
    
    while(cin >> t)
    {
        long long sum;
        
        sum = ((t*(t+1)/2) % 10000) * ((t*(t+1)/2) % 10000) % 10000;
        printf("%04lld\n", sum);
    }
    
    return 0;
}

 


 

1到n的立方和的公式——1³+2³+3³+.+n³=[n(n+1)]²/4

立方和公式——formula

立方差公式——formula

int 的取值范围 -2147483648~2147483647(-2^31~2^31-1)

long、long long 的取值范围 -9223372036854775808~9223372036854775807(-2^63~2^63-1)

 

转载于:https://www.cnblogs.com/limyel/p/6622642.html

评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值