hdu-2114-Calculate S(n)

Calculate S(n).

S(n)=13+23 +33 +……+n3 .

Input
Each line will contain one integer N(1 < n < 1000000000). Process to end of file.

Output
For each case, output the last four dights of S(N) in one line.

Sample Input
1
2

Sample Output
0001
0009

前n项立方和的公式:(n*(n+1)/2)^2;,注意这里要用__int64,用int会一直WA

#include<iostream>
#include<cstring>
#include<cstdio>
using namespace std;
int main()
{
   __int64 n,i;
   while(cin>>n)
   {
n=n%10000;
       i=(((n*(n+1)/2))*((n*(n+1)/2)))%10000;
       printf("%04I64d\n",i);
   }
    return 0;
}
  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值