【HDU - 2114】 Calculate S(n) (立方和)

Calculate S(n). 

S(n)=1 3+2 3 +3 3 +......+n 3 .

Input

Each line will contain one integer N(1 < n < 1000000000). Process to end of file.

Output

For each case, output the last four dights of S(N) in one line. 

Sample Input

1
2

Sample Output

0001
0009

做这道题只要知道立方和公式就非常简单了。S_n=\frac{1}{4}*n^2*(n+1)^2

n的平方的前n项和公式:n(n+1)(2n+1)/6

ac代码:

 

#include<iostream>
#include<stdio.h>
#include<algorithm>
#include<math.h>
#include<cstring> 
#include<string.h>
#include<queue>
using namespace std;
typedef long long ll;
long long  a[50050];
int main()
{
	ll n;
	while(scanf("%lld",&n)!=EOF)//开始外面n设置成ll,里面结果用Int取得,wr了
	{
		printf("%04lld\n",(((n*(n+1)/2)%10000)*((n*(n+1)/2)%10000))%10000);这个地方要对10000取模
	}
	return 0;
 } 

 

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值